No se puede extender ListFragment – "Llamada requiere API nivel 11"

Estoy tratando de extender ListFragment, pero sigo recibiendo el error indicado anteriormente. He añadido la biblioteca de soporte de Android a mi proyecto.

Usted probablemente tiene la importación equivocada en su proyecto / clase. Es probable que extienda ListFragment de la API 11 (android.app.ListFragment) y debe extender ListFragment de la clase de compatibilidad ( android.support.v4.app.ListFragment )

Trate de añadir

 import android.support.v4.app.Fragment; import android.support.v4.app.ListFragment; 
  • Diseño con fragmento y framelayout sustituido por otro fragmento y framelayout
  • Proguard Android App para compatibilidad con LVL y fragmentos compatibles
  • Comprobar la existencia de un fragmento usando Robotium - Android
  • ¿Cómo resalto el texto buscado en mi filtro de búsqueda?
  • Vista de lista de Android dentro de un fragmento
  • Integración de OSMDroid con fragmentos
  • ViewPager en DialogFragment - IllegalStateException: Fragmento no tiene una vista
  • Establecer el color de la barra de estado desde DialogFragment
  • Cuándo usar FragmentManager :: putFragment y getFragment
  • De error de memoria durante el uso de viewpager + imageview incluso cuando se utiliza la memoria caché y asynctask
  • La interfaz de usuario no se actualiza después de cambiar primero el menú deslizante en Android 5.0 lollipop
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.