Cómo arreglar eror app \ build \ intermedios \ res \ fusionado \ debug \ valores-v24 \ valores-v24.xml

Consigo un error cuando construyo un proyecto.

Error:

Error:Execution failed for task ':app:processDebugResources'. > com.android.ide.common.process.ProcessException: Failed to execute aapt C:\Users\MR Maleki\Desktop\WhoIsBetter2\app\build\intermediates\res\merged\debug\values-v24\values-v24.xml Error:(4) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Colored'. Error:(3) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Borderless.Colored'. Error:(3) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Borderless.Colored'. Error:(4) Error retrieving parent for item: No resource found that matches the given name 'android:TextAppearance.Material.Widget.Button.Colored'. 

Gradle:

  compileSdkVersion GLOBAL_COMPILE_SDK as int buildToolsVersion GLOBAL_BUILD_TOOLS compile fileTree(include: ['*.jar'], dir: 'libs') //----------------- Android Support Library -------------------------------- compile "com.android.support:appcompat-v7:$GLOBAL_SUPPORT_LIBRARY_VERSION" compile "com.android.support:design:$GLOBAL_SUPPORT_LIBRARY_VERSION" compile "com.android.support:gridlayout-v7:$GLOBAL_SUPPORT_LIBRARY_VERSION" compile "com.android.support:cardview-v7:$GLOBAL_SUPPORT_LIBRARY_VERSION" 

¿Cómo debo corregir este error? ¿Qué recomendaría para solucionar el problema?

Esto normalmente ocurre cuando la versión principal de la biblioteca de soporte no coincide con la versión de compilación de SDK.

Por ejemplo, si está compilando con SDK versión 24, debe utilizar la versión 24.xx de la biblioteca de soporte (y viceversa).

Véase también: Error al recuperar el padre del elemento: No se encontró ningún recurso que coincida con el nombre dado después de actualizar a AppCompat v23

  • Cómo usar setImageTintList () en la API de Android <21
  • GetSupportActionBar desde el interior de Fragment ActionBarCompat
  • Biblioteca de soporte técnico de Android appcompat_v7 v21.0.1 da error
  • Soporte de la barra de acciones v7 android
  • NotificationBuilder.setProgress no hace nada en 2.3.5
  • Error de dependencia de android-support-v4.jar
  • TabLayout se bloquea después de actualizar la biblioteca de soporte a 23.2.0
  • Los fragmentos anidados desaparecen durante la animación de transición
  • ¿Por qué ContextThemeWrapper está ahora restringido al grupo Support Library?
  • Establecer el estado de BottomSheetDialogFragment a expandido
  • Barra de herramientas Navegación Icono de Hamburger ausente
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.