Android Studio 1.0.2 m2responsory gradle issue

Utilizando Android Studio 1.0.2, y se ve obligado a utilizar Gradle 2.2.1, todas las variables del sistema son correctas. Con la nueva actualización hay problemas con versiones anteriores de gradle y m2repository. Estoy intentando importar el ejemplo de kickflip.io android ( https://github.com/Kickflip/kickflip-android-example ).

Estoy viendo este error:

Could not find com.android.tools.build:gradle:2.2.1. Searched in the following locations: file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/2.2.1/gradle-2.2.1.pom file:/C:/Program Files/Android/Android Studio/gradle/m2repository/com/android/tools/build/gradle/2.2.1/gradle-2.2.1.jar https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.1/gradle-2.2.1.pom https://repo1.maven.org/maven2/com/android/tools/build/gradle/2.2.1/gradle-2.2.1.jar Required by: :kickflip-android-example-master:unspecified 

He mirado en m2repository y veo:

 C:\Program Files\Android\Android Studio\gradle\m2repository\com\android\tools\build\gradle\1.0.0 

¿Cómo puedo añadir la biblioteca 2.2.1?

Gradle Wrapper:

 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=http\://services.gradle.org/distributions/gradle-2.2.1-all.zip 

Archivo de construcción de nivel superior:

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:2.2.1' classpath 'org.codehaus.groovy:groovy-backports-compat23:2.3.5' } } allprojects { repositories { mavenCentral() } } 

App / build.gradle:

 buildscript { repositories { maven { url 'http://repo1.maven.org/maven2' } } } android { compileSdkVersion 19 buildToolsVersion "19.1" defaultConfig { minSdkVersion 18 targetSdkVersion 19 versionCode 2 versionName "1.1" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } compileOptions { sourceCompatibility JavaVersion.VERSION_1_7 targetCompatibility JavaVersion.VERSION_1_7 } } dependencies { compile 'com.android.support:support-v4:19.1.0' compile 'com.squareup.picasso:picasso:2.2.0' compile 'com.readystatesoftware.systembartint:systembartint:1.0.3' compile 'io.kickflip:sdk:1.1.1' } 

Mi informe de error es extremadamente largo, así que no lo publicaré puesto que el formato consigue corrompido cuando lo copio y lo pego adentro. Cualquier ayuda es apreciada grandemente.

La versión de Gradle es 2.2.1, pero estás conectando eso al lugar donde se encuentra el número de versión del complemento de Android Gradle. Eso es actualmente en 1.0.0. En lugar de esto:

  classpath 'com.android.tools.build:gradle:2.2.1' 

utilizar esta:

  classpath 'com.android.tools.build:gradle:1.0.0' 

Si, funciona.

En primer lugar, el repositorio jcenter no incluye la versión 2.2.1. así que necesita cambiar a 1.0.0 / 1.0.1

  • Cree la Biblioteca de Archivos de Android (AAR) con maven solamente
  • Excepción Gradle de Android: "Multiple dex files define", clases duplicadas bajo exploded-aar
  • ¿Cómo puedo hacer mi proyecto de Android disponible desde el control remoto usando gradle como Picasso, Volley, etc?
  • Adición de dependencias de Maven a Gradle en Android Studio
  • Construir el proyecto android desde la línea de comandos con diferentes urls / Environment
  • Android Library Package perdió el nombre de los parámetros de las interfaces internas
  • Compatibilidad con versiones anteriores del diseño del material: colorAccent requiere el nivel 21 de API cuando se utiliza appcompat7
  • IntelliJ importa proyecto de POM usando la versión incorrecta de JDK
  • MAVEN SDK no válido: Nivel de plataforma / API 16 no disponible
  • ¿Cómo liberar un AAR con otra dependencia del proyecto de la biblioteca de android?
  • Error en el archivo xml de maven pom: Creando un proyecto Android
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.