Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


UnsupportedMethodException Android Studio 0.8.9

Tengo Android Studio 0.8.9. Hasta ahora, podría sincronizar con los archivos gradle con éxito, pero hoy cuando lo abrí, me da este error:

UnsupportedMethodException Failed to set up Android modules in project 'Project': Unsupported method: SourceProvider.getJniDirectories(). The version of Gradle you connect to does not support that method. To resolve the problem you can change/upgrade the target version of Gradle you connect to. Alternatively, you can ignore this exception and read other information from the model. 

¿Me puede ayudar a resolver esto? Gracias.

  • CompileKotlin bloquea en archivo build.gradle lanza error "No se pudo encontrar el método compileKotlin () para los argumentos "
  • En una versión de gradle de Android, cambie el contenido de strings.xml durante la compilación
  • App-debug-unaligned.apk especificado para la propiedad 'inputFile' no existe
  • En Android / Gradle cómo definir una tarea que sólo se ejecuta al construir buildType específico / buildVariant / productFlavor (v0.10 +)
  • Ejecución fallada para la tarea: app: compileDebugJavaWithJavac en Android Studio
  • Android Gradle Project actualizando herramientas de compilación a 21.0.1: aapt lanza Exception
  • "No ha especificado una vista para utilizarla como contenido para ventanas emergentes"
  • Generación dinámica de sabores de productos
  • 2 Solutions collect form web for “UnsupportedMethodException Android Studio 0.8.9”

    Como se ha dicho por Justin , la actualización a Android Studio 0.9.0 corrige este problema.

    Para corregir este problema he degradado el android-plugin en su archivo de nivel superior build.gradle de los proyectos de classpath 'com.android.tools.build:gradle:0.14.+' to classpath 'com.android.tools.build:gradle : 0,13. + '

    Así que ahora mismo el método buildscript en mis proyectos build.grade parece

     buildscript { repositories { mavenCentral() } dependencies { // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files classpath 'com.android.tools.build:gradle:0.13.+' } } 

    Creo que puede haber un error con la versión .14, envié mi informe de errores.

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.