Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Suprimir AndroidManifest.xml Advertencia relacionada con minSdkVersion

Como se recomienda aquí http://developer.android.com/guide/practices/screens_support.html por razones de compatibilidad, mi AndroidManifest.xml contiene lo siguiente:

<uses-sdk android:minSdkVersion="3" android:targetSdkVersion="4"/> 

Esto genera una advertencia en eclipse:

El atributo minSdkVersion (3) es inferior al nivel de la API de destino del proyecto (4)

¿Hay algún medio para suprimir esta advertencia o deshacerse de ella de otra manera? Es realmente molesto.

  • Android Studio - elimina la advertencia de excepción de seguridad
  • Android Studio: suprimir advertencia de pelusa para la instrucción if
  • Crear una anotación Java con comportamiento contextual IDE
  • Cómo suprimir la advertencia "Se puede reemplazar con foreach"
  • Nivel de la API de Android <19 y "prueba puede utilizar la administración de recursos automática" warning
  • Cómo suprimir Android Lint advertencia en Gradle script
  • ¿Qué es @SuppressWarnings ("depreciación") y ("no utilizado") en Android?
  • 3 Solutions collect form web for “Suprimir AndroidManifest.xml Advertencia relacionada con minSdkVersion”

    En resumen, no hay una forma integrada de hacer esto que yo sepa.

    Aquí hay una discusión de agosto pasado.

    Y aquí está la respuesta de Xavier Durochet.

    Parece que se puede eliminar manualmente de acuerdo a la respuesta de Mark Murphy en el primer hilo:

    O bien, puede modificar SetupTask.java, eliminar esta prueba (líneas 297-308 del código indexado por Google Code Search) y crearla en una versión personalizada de la extensión Android Ant

    Hay una solicitud de característica que puede tratar con esto, pero quién sabe cuándo se implementará.

    La respuesta de 2011 ya no es exacta. Se fijó en ADT 17 de acuerdo con este error .

    Esta advertencia es habitual. Estoy usando minSdkVersion para apoyar Android 1.5 y estoy construyendo para Android 1.6 para apoyar pantallas pequeñas. Puede crear su aplicación con la última biblioteca de Android 2.3, pero todavía admite una versión inferior.

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.