¿Qué versión de la biblioteca de soporte está instalada en mi Android Studio

Intenté agregar un CardView en mi aplicación así que agregué la dependencia siguiente en mi gradle

compile 'com.android.support:cardview-v7:22.2.1'

Me di cuenta de que se ha producido un error porque he dado el número de versión incorrecto. Después de echar un vistazo a los documentos oficiales de google llegué a saber que el Android Support Repository se utiliza para contener bibliotecas appcompat . Introduzca aquí la descripción de la imagen

Como puede ver el repositorio de Soporte que he instalado es la versión 33. Pero si cambio mi gradle a la versión 33 todavía está mostrando error.

¿Cómo puedo comprobar qué versión de AppCompatLibrary tengo en android studio?

EDITAR:

Archivo build.gradle

 apply plugin: 'com.android.application' apply plugin: 'com.google.gms.google-services' android { compileSdkVersion 22 buildToolsVersion "23.0.3" defaultConfig { applicationId "com.spintum.preexam" minSdkVersion 19 targetSdkVersion 22 versionCode 1 versionName "1.0" multiDexEnabled true } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } repositories { mavenCentral() } dependencies { // compile fileTree (dir:'libs',include:'achartengine-*.jar') //compile fileTree('libs/achartengine-1.1.0.jar') compile fileTree(include: ['*.jar'], dir: 'libs') testCompile 'junit:junit:4.12' compile 'com.android.support:percent:22.2.0' compile 'com.android.support:design:22.2.1' compile 'com.android.support:appcompat-v7:22.2.1' compile 'com.android.support:support-v4:22.2.0' compile 'com.android.support:cardview-v7:+' //compile 'com.android.support:recyclerview-v7:22.2.+' compile 'com.google.code.gson:gson:2.3.1' compile 'com.google.android.gms:play-services:8.3.0' compile 'com.google.android.gms:play-services-auth:8.3.0' compile 'com.google.android.gms:play-services-identity:8.3.0' compile 'com.google.android.gms:play-services-plus:8.3.0' compile 'com.google.android.gms:play-services-location:8.3.0' compile 'com.android.support:multidex:1.0.0' compile 'com.github.markushi:circlebutton:1.1' compile 'com.facebook.android:facebook-android-sdk:4.0.0' compile 'de.hdodenhof:circleimageview:2.1.0' compile 'com.ToxicBakery.viewpager.transforms:view-pager-transforms:1.2.32@aar' } 

Compruebe su carpeta SDK y vea cuál es el número existente más alto:

Por ejemplo, B: \ android-sdk \ extras \ android \ m2repository \ com \ android \ support \ appcompat-v7

Habrá una carpeta para cada versión instalada. En el momento de escribir este artículo, 24 es la última versión.

No se trata de la versión instalada del repositorio de soporte de Android.

La versión que debe estar en los archivos de compilación de Gradle debe ser la versión más alta del número correspondiente a su

compileSdkVersion

En tu AppLevel Gradle Build File (por defecto es el módulo de la aplicación ).

Ejemplo:

Si está utilizando compileSdkVersion 23 , debe comprobar su siguiente directorio para la carpeta 23.xx más alta.

\ YOUR-SDK-PATH \ extras \ android \ m2repository \ com \ android \ soporte \ cardview-v7

Supongamos que su número más alto a partir de 23 es 23.4.0, entonces debería usar este número de versión ( 23.4.0 reemplazando el 33.0.0 ) para su archivo de compilación de Gradle (No es la versión del repositorio de soporte de Android instalado).

Significa que tienes que usar las bibliotecas de repositorios de Android Support de acuerdo con tu compilaciónSdkVersion.

  • Uso de libpd en Android Studio
  • ¿Cómo generar reportes de findbugs usando gradle script?
  • No se puede crear Debug Bridge No se puede detectar la versión de adb. Error de sintaxis: ")" Actualización de Platform-tools 23.0.1 a 23.1.0 Linux-32 bits causa problema
  • Android Studio 1.0.1 agrega bibliotecas externas
  • ¿Cómo puedo comprobar qué versión de plugin de Gradle Android se utiliza en mi proyecto?
  • Carpetas orientables de Android Studio
  • Android Studio y MonkeyTalk?
  • ¿Por qué ViewPager genera errores en el modo de diseño de Android Studio?
  • Fusión de manifiesto falló al intentar agregar mi propio logotipo a la aplicación Android - Android Studio
  • No puede instalar el repositorio y el proyecto de sincronización - no puede utilizar las bibliotecas de soporte 25.2.0
  • Cambiar entre previsualización de referencia y valor de recursos de cadena en el editor xml
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.