Problemas de instalación del complemento de Android en eclipse

Estoy intentando instalar el ADT Plugin. Voy a ayudar a instalar el nuevo software en eclipse y después de seleccionar la herramienta de desarrollo obtengo este error

Cannot complete the install because one or more required items could not be found. Software being installed: Android Traceview 16.0.1.v201112150204-238534 (com.android.ide.eclipse.traceview.feature.group 16.0.1.v201112150204-238534) Missing requirement: Android Traceview 16.0.1.v201112150204-238534 (com.android.ide.eclipse.traceview.feature.group 16.0.1.v201112150204-238534) requires 'org.eclipse.ui 3.6.2' but it could not be found 

EDIT Tengo eclipse 3.5.2

14 Solutions collect form web for “Problemas de instalación del complemento de Android en eclipse”

No encontré ninguna solución para esto. Pero en lugar de usar eclipse instalado con

Sudo apt-get install eclipse

Lo he descargado desde una página web y empiezo ese (descargado) eclipse, y con esa versión funciona muy bien

Primero debe instalar GEF y WST.

Sitio de actualización de GEF: http://download.eclipse.org/tools/gef/updates/releases/ (muerto)

Sitio de actualización de WST: http://download.eclipse.org/releases/galileo

Tuve el mismo problema, ejecutar eclipse como administrador e intentar instalar ADT plugin de nuevo, funciona.

Parece que hay algún desajuste de versión. ¿Está utilizando eclipse 3.6.2 o versión anterior?

http://developer.android.com/sdk/eclipse-adt.html menciona que ADT 16.0.1 requiere eclipse versión 3.6 y superior.

Además, solo comprueba si has instalado o actualizado el SDK android más reciente antes de actualizar el adt. Eso podría ayudar en su caso.

En caso de que no puedas actualizar tu Eclipse (como yo). Utilice esto como archivo local para instalar ADT 15.0.0 que admita Eclipse 3.5.

http://dl.google.com/android/ADT-15.0.0.zip

¡Encontré que usar una versión 64bit de eclipsed me dio ese error! Intenta usar la versión de 32 bits y ver si eso lo arregla. =)

Yo tuve el mismo problema. Lo solucioné abriendo el eclipse en la consola con: sudo eclipse

Solo necesitas Ecplise Helios

ADT 16.0.1 (diciembre de 2011)

Dependencias:

  Eclipse Helios (Version 3.6) or higher is required for ADT 16.0.1. ADT 16.0.1 is designed for use with SDK Tools r16. If you haven't already installed SDK Tools r16 into your SDK, use the Android SDK Manager to do so. 

Tomado de http://developer.android.com/sdk/eclipse-adt.html

En Ubuntu 11.10,

Descargé Eclipse usando sudo apt-get install eclipse

  • SDK Android instalado
  • Instalado ADT PLugin en Eclipse (Eclipse debe iniciarse con sudo contrario obtendrá el error mencionado por lukap)

Hay una solución fácil para él apenas selecciona la opción todos los sitios disponibles. En el trabajo con .. espacio y selecciona los paquetes androides que deseas instalar

En Windows 7, seleccione 'Ejecutar como administrador' al abrir eclipse. Esto le da a eclipse los permisos que necesita y debe eliminar el error. Esto funcionó para el programa de 64 bits.

Tuve problemas similares, tratando de instalar ADT plugin, pero no exactamente lo mismo.

Lo arreglé en ir a Ayuda> Buscar actualizaciones, y acaba de instalar las actualizaciones disponibles, reiniciado Eclipse, y luego intentó instalar ADT plugin de nuevo, y funcionó muy bien.

Yo estaba usando eclipse (helios versión 3.6.2) y trató de instalar SDK android, pero no con el error abovee mencionado.

Encontré la solución para este problema.

Seleccione la lista "Sitios de software disponibles"

http://download.eclipse.org/releases/helios/201102250900 (Helios) y http://download.eclipse.org/releases/helios (Helios Milestone Repository)

Si utiliza galileo, seleccione la línea de liberación apropiada de la lista de sitios disponibles. 'Buscar actualizaciones' (para obtener las actualizaciones de Helios), luego instale el complemento.

Para la instalación nativa (probado en xubuntu) – por favor vea el video

http://www.youtube.com/watch?v=HCNC34BflOo&feature=player_embedded# !

dentro de poco:

1) Ejecutar eclipse de

Root-> ayuda -> instalar nuevo software -> agregar

Nombre: update (S), url: http://download.eclipse.org/releases/indigo (para 3.7.x, juno para 4.2.x)

O seleccione en el menú "trabajar con" si existe ruta

2) seleccionar 'linux development' instalar, todos los warnig / error pakages off

3) instalar ADT Plugin después de la instalación reinicie eclipse y seleccione path-to-android-sdk

4) Tape (Escribir) error a nuestro distribuidor distribuidor Linux 🙂

¡Disfrutar! PS Separar instalar – buena idea 🙂

  • Dispositivo LG no listado en dispositivos ADB
  • Colorear las líneas de logcat en Linux
  • Plugin para Android de Eclipse - libncurses.so.5
  • ¿Por qué puedo mover con éxito un archivo en Linux mientras se está escribiendo?
  • AVD no se inicia (sin mensaje de error)
  • ¿Cómo obtener una mayor precisión de "CPU%" que la del comando TOP?
  • Android studio en 64 bits OS que ejecutan 64 bits OS dan ERROR: 32-bit Linux Los binarios del emulador de Android son DEPRECATED
  • android no puede encontrar un objetivo
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.