No se puede instalar Android Studio en Ubuntu

Estoy usando Ubuntu Gnome 14.04, y tengo Java 8 instalado (tanto el JDK y el JRE).

Cuando estaba instalando Android Studio todo funcionaba, pero apareció un mensaje diciendo:

No se puede ejecutar la herramienta mksdcard SDK

¿Cómo puedo instalar Android Studio correctamente o cómo puedo solucionarlo?

Suponiendo que está ejecutando el 64bit Ubuntu, la solución sugerida para el "Problema 82711 " debería resolver su problema.

sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

Actualización: Para Ubuntu 15.10 y 16.04 sudo apt-get install lib32z1 lib32ncurses5 lib32stdc++6

@warsong tiene razón. Instalar sólo lib32stdc++6 resolvió el problema.

Para los usos siguientes reescribo el comentario de @warsongs en el área de la respuesta.

 sudo apt-get install lib32stdc++6 

Actualización:

Para Ubuntu 15.04,15.10,16.04 LTS y Debian 8

Para Fedora (probado para Fedora 23/24) ejecutar

 dnf install compat-libstdc++-296 compat-libstdc++-33 glibc libgcc nss-softokn-freebl libstdc++ ncurses-libs zlib-devel.i686 ncurses-devel.i686 ant 

Entiendo que la pregunta es acerca de UBUNTU, pero tuve un problema similar en Debian Jessie 64bit y sugerencia warsongs trabajado para él también.
Cuando funcioné studio.sh el estudio del androide comenzaría, pero cuando intenté configurar el androide SDK conseguí el error
Unable to run mksdcard SDK tool
Cuando lo intenté
sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6
Error conseguido
E: Package 'lib32bz2-1.0' has no installation candidate
Así que tomó warsongs sugerencia y sólo trató de instalar lib32stdc ++ 6.
sudo apt-get install lib32stdc++6
Después de esto fue capaz de agregar el SDK de Android en Android Studio.

Ver esta página

Si está ejecutando una distribución de 64 bits en su máquina de desarrollo, primero debe instalar paquetes adicionales. Para Ubuntu 13.10 (Saucy Salamander) o superior, instale los libncurses5:i386 , libstdc++6:i386 y zlib1g:i386 usando apt-get :

 sudo dpkg --add-architecture i386 sudo apt-get update sudo apt-get install libncurses5:i386 libstdc++6:i386 zlib1g:i386 

El problema se debe a que mksdcard no se ha instalado correctamente.

Si está ejecutando 64 bits, haga esto para solucionar el problema mksdcard.

  sudo dpkg --add-architecture amd64 sudo apt-get update sudo apt-get install libncurses5:amd64 libstdc++6:amd64 zlib1g:amd64 

Y 32 bits:

  sudo dpkg --add-architecture i386 sudo apt-get update sudo apt-get install libncurses5:i386 libstdc++6:i386 zlib1g:i386 

En SDK 6.0, el mensaje de error es diferente, pero significa lo mismo.

  Unable to run mksdcard 

Ninguna de estas opciones funcionó para mí en Ubuntu 12.10 (sí, tengo que actualizar). Sin embargo, encontré una solución fácil. Descargue la fuente de aquí: https://github.com/miracle2k/android-platform_sdk/blob/master/emulator/mksdcard/mksdcard.c . A continuación, simplemente compilar con "gcc mksdcard.c -o mksdcard". Copia de seguridad de mksdcard en la subcarpeta de herramientas de SDK y reemplácela por la compilada nuevamente. Android Studio ahora estará contento con su SDK.

Para Linux Mint ejecutar

 sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0 lib32stdc++6 

Si ejecuta sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0 lib32stdc++6 y sudo apt-get install lib32z1 lib32ncurses5 libbz2-1.0 lib32stdc++6 un mensaje como: " The following packages have unmet dependencies: lib32stdc++6 : Depends: lib32gcc1 (>= 1:4.1.1) ".

Usted puede hacer algo como esto tut: https://askubuntu.com/questions/671791/lib32stdc6-package-depends-on-gcc-base-but-my-installed-version-is-newer

Este problema surge cuando su oso de 64 bits intenta instalar el SDK de Android que a su vez intenta instalar algunos binarios de 32 bits y por lo tanto es el problema de la compatibilidad.

Abra un terminal adicional y escriba

 sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6 

Ayudaría a instalar todos los binarios necesarios. Después de esto, inicie de nuevo el proceso de instalación de Android SDK.

  • Error al crear AOSP para Ubuntu 15.04 desde el subconjunto Maestro de construcción interrumpido
  • No se puede encontrar la carpeta .android en ubuntu
  • El comando adb devices no muestra nada
  • Inicio fallido: Error interno al iniciar Android Studio en ubuntu
  • No se puede iniciar un nuevo proyecto con Android Studio
  • No se puede ejecutar android / sdk / build-tools / 23.0.2 / aapt
  • El botón de ejecución está deshabilitado en Android Studio
  • Android Emulator no funciona en Ubuntu después de actualizar Android Studio a 2.0 - Biblioteca Qt no encontrada
  • Emulador de Android Ubuntu 14.04 no se pudo crear la ventana SDL2 GLX no compatible
  • Problemas de instalación de ADT Plugin Eclipse 3.7 Ubuntu 11.10
  • ¿Cómo construir un proyecto android con openjdk en Ubuntu?
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.