No se pudo encontrar la propiedad 'VERSION_CODE'

Quiero usar esta biblioteca para mi proyecto y tengo error cuando intento abrir esta biblioteca (FloatingActionButton) fuente de Github.

Puedo descargar como zip este proyecto cuando traté de abrir el código fuente para entenderlo, tengo este error:

Error:(10, 0) Could not find property 'VERSION_CODE' on project ':library'. 

Añadir build.gradle

 apply plugin: 'com.android.library' android { compileSdkVersion 22 buildToolsVersion "22.0.1" defaultConfig { minSdkVersion 14 targetSdkVersion 22 versionCode Integer.parseInt(project.VERSION_CODE) versionName project.VERSION_NAME } buildTypes { release { minifyEnabled false debuggable false } debug { minifyEnabled false debuggable true } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) } apply from: '../gradle-mvn-push.gradle' 

4 Solutions collect form web for “No se pudo encontrar la propiedad 'VERSION_CODE'”

Import library como un módulo, cambie versionCode y versionName a valores aleatorios, agregue una referencia a su proyecto – agregue al compile project(":library") dependencias compile project(":library") y elimine:

Aplicar de: '../gradle-mvn-push.gradle'

Para usar la nueva biblioteca de soporte de diseño, necesitas escribir la siguiente línea en el archivo gradle de tu aplicación

 compile 'com.android.support:design:22.2.0' 

Y en su archivo layout.xml escriba las siguientes líneas

  <android.support.design.widget.FloatingActionButton android:id="@+id/floating_action_button" android:layout_width="wrap_content" android:layout_height="wrap_content" android:layout_margin="@dimen/fab_margin" android:src="@drawable/your_icon" app:borderWidth="0dp" app:layout_anchor="@id/coordinator_layout" app:layout_anchorGravity="bottom|right|end" /> 

Eso es

El proyecto que descargaste no parece tener un archivo AndroidManifest, por lo que no tiene un VERSION_CODE ni un VERSION_NAME. Cuando se incorpora el código en su proyecto, se obtendrá desde el archivo de manifiesto en su proyecto. O eso espero.

Importar biblioteca como un módulo por,

 1. File-> New-> ImportModule-> SoureDirectory-> "your library path" -> ok. 2. Change versionCode and versionName to the same as in android-Floating-button/sample/build.gradle (copy that 2 from app build.gradle to library build.gradle) ( for example give: versionCode 1, versionName "1.0"), 3. (CTRL+ALT+SHIFT+S) or Go to File > Project Structure > Modules --> Click on "Dependencies" -> click on "+"(plus) -> Module Dependency -> select you lib-> "OK". 4. Remove this from build.grade in you "library" apply from: './gradle-mvn-push.gradle' 5. Add this in you app "build.gradle" like this dependencies { compile project(":library") } 
  • ¿Cómo desinstalar completamente el SDK de tejido de Twitter del proyecto android?
  • Gradle build falló en Android Studio versiones nuevas y viejas en OSX
  • Gradle define el valor de la ruta absoluta para un archivo de almacén de claves
  • ¿Cómo construir Android gradle proyecto que contiene módulos con diferentes compileSdkVersion, targetSdkVersion y minSdkVersion?
  • Uso de la función gradleReference en cordova plugin.xml
  • Muchos módulos pequeños, o pocos módulos grandes para el mejor rendimiento de la construcción?
  • Ejecutar pruebas de JUnit en la aplicación de Gradle para Android
  • Gradle Error: Error de ejecución para la tarea ': app: processDebugGoogleServices'
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.