No se pudieron resolver todas las dependencias para la configuración ': classpath'

No puedo parecen obtener herramientas de construcción para el último gradle en absoluto. Sospecho que tiene algo que ver con la configuración de proxy para gradle. He tenido un buen aspecto en línea, pero aún no puedo parece encontrar una solución. Utilizo gradle 2.1.

Creé el archivo gradle.properties en mi carpeta /home/user/.gradle con esta configuración.

SystemProp.http.proxyHost = proxy systemProp.http.proxyPort = 80 systemProp.http.proxyUser = myusername systemProp.http.proxyPassword = contraseña

SystemProp.https.proxyHost = proxy systemProp.https.proxyPort = 80 systemProp.https.proxyUser = myusername systemProp.https.proxyPassword = contraseña

Aquí está mi build.gradle global

buildscript { repositories { mavenLocal() mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.13.0' classpath fileTree(dir: 'build-libs', include: '*.jar') } } allprojects { repositories { mavenCentral() } } 

Y aquí está el error que obtengo al ejecutar grawlew Could not HEAD ' https://repo1.maven.org/maven2/com/android/tools/build/gradle/0.13.0/gradle-0.13.0.pom '. Par no autenticado

¿Qué me estoy perdiendo? Que el enlace de maven se abre bien en un navegador.

Im derecho no estoy seguro de si va a trabajar para otros, pero trabajó para mí.

Cambié el proxyPort a 8080 y usé jcenter en vez de Maven. Pero tuve que aplicar expeption para usar HTTP en lugar de HTTPS. Esto es lo que tengo en mi gradle.build para script de compilación y todos los proyectos

 buildscript { repositories { jcenter { url "http://jcenter.bintray.com/" } } } allprojects { repositories { jcenter { url "http://jcenter.bintray.com/" } } } 

ACTUALIZACIÓN: 06/08

Recientemente he actualizado Gradle y versión de plugin y tenía algunos problemas. Se quejaba de plugin com.android.application

Hice un poco de excavación y cambió

  jcenter { url "http://jcenter.bintray.com/" } 

a

  repositories { maven { url 'http://repo1.maven.org/maven2' } } 

Intento modificar los repositorios e importar el cer a java, pero ambos fallaron, después actualizo mi versión de jdk de 1.8.0_66 a 1.8.0_74, gradle construye éxito.

Tarde, pero funcionó para mí:
Cambiar su configuración de dns por ir a la red y el centro de intercambio .
En el panel izquierdo, elija cambiar el ajuste del adaptador
Haga clic derecho en su conexión de red
Propiedades
-seleccionar ipv4
Propiedades
– ahora en la configuración del servidor dns: –
-elige la opción utilizar las siguientes direcciones de servidor dns
Y utilizar el servidor de google dns 8.8.8.8 como servidor dns preferido y 8.8.4.4 como servidor dns alternativo .

Resolverá su problema.

  • Charles ssl certificado de descarga no "debido a fallos de red"
  • Cómo obtener la configuración del proxy WiFi en Android
  • com.android.volley.NoConnectionError - Emulador de Android con Charles Proxy
  • Establecer SDK de Android detrás del servidor proxy?
  • ¿Cómo puedo conectarme a un proxy en Android?
  • Configuración de la red del emulador de Android
  • El host remoto cerró la conexión durante el apretón de manos: Certificado Burp en Android
  • Charles SSL Proxy funciona para cromo pero no para las aplicaciones
  • Primera ejecución de Android Studio. No se puede acceder a la lista de complementos SDK de Android
  • Configurar Http Proxy en Android Studio
  • Cómo capturar tráfico de aplicaciones en Android
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.