Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


MapActivity no se puede resolver con un tipo, ni siquiera con el objetivo de API de Google

También obtengo "la importación com.google no puede ser resuelta a un tipo", y no estoy seguro de si está relacionado, pero mi proyecto funciona bien en Android 2.3.3, pero se congela al arrancar en la API de Google 2.3.3 y 4,0,

Ps he incluido

<uses-library android:name="com.google.android.maps" /> 

¡Por favor ayuda! Gracias

2 Solutions collect form web for “MapActivity no se puede resolver con un tipo, ni siquiera con el objetivo de API de Google”

Es necesario hacer referencia a la biblioteca correcta en tiempo de compilación. Pero lo que describe es pedirle a Android que use esta biblioteca específica en tiempo de ejecución.

Necesita hacer clic con el botón derecho del ratón en su proyecto Eclipse, Propiedades -> Android. En Project Build Target seleccione cualquier objetivo con el proveedor Google Inc. ..

El problema es que usted no está usando el Google Api para la plataforma específica de Android Simplemente checing la API de destino de Google apropiado resolverá el problema.

Introduzca aquí la descripción de la imagen

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.