Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Jenkins no puede resolver com.android.tools.build:gradle:3.0.0-alpha8

He actualizado a Android Studio versión 3.0 Canary 8 y seguido el auto-prompt en Android Studio para actualizar la versión androide gradle plugin a "3.0.0-alpha8".

Mi compilación Jenkins ahora no logra resolver "com.android.tools.build:gradle:3.0.0-alpha8.". A continuación se muestran los registros de errores de compilación

Could not resolve all files for configuration ':classpath'. Could not find com.android.tools.build:gradle:3.0.0-alpha8. Searched in the following locations: https://jcenter.bintray.com/com/android/tools/build/gradle/3.0.0-alpha8/gradle-3.0.0-alpha8.pom https://jcenter.bintray.com/com/android/tools/build/gradle/3.0.0-alpha8/gradle-3.0.0-alpha8.jar https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.0.0-alpha8/gradle-3.0.0-alpha8.pom https://dl.google.com/dl/android/maven2/com/android/tools/build/gradle/3.0.0-alpha8/gradle-3.0.0-alpha8.jar https://maven.fabric.io/public/com/android/tools/build/gradle/3.0.0-alpha8/gradle-3.0.0-alpha8.pom https://maven.fabric.io/public/com/android/tools/build/gradle/3.0.0-alpha8/gradle-3.0.0-alpha8.jar 

Mi proyecto raíz build.gradle es el siguiente:

 buildscript { repositories { jcenter() google() // maven { url "https://maven.google.com" } does not work as well maven { url 'https://maven.fabric.io/public' } } dependencies { classpath 'com.android.tools.build:gradle:3.0.0-alpha8' classpath 'com.google.gms:google-services:3.1.0' classpath 'io.fabric.tools:gradle:1.23.0' } } 

El mismo código se genera correctamente en Android Studio, pero falla en Jenkins

2 Solutions collect form web for “Jenkins no puede resolver com.android.tools.build:gradle:3.0.0-alpha8”

Debe agregar esta url en sus repositorios raíz build.gradle:

  maven { url 'https://maven.google.com' } 

Me gusta esto:

 buildscript { repositories { jcenter() mavenCentral() // add repository maven { url 'https://maven.google.com' } } } 

Saludos

Para obtener el mejor rendimiento, debe utilizar la última versión posible de Gradle y el complemento de Android. Introduzca aquí la descripción de la imagen

Edite su gradle-wrapper.properties

 distributionUrl = https\://services.gradle.org/distributions/gradle-3.3-all.zip 

La última distribución de gradle se puede encontrar aquí

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.