Intentando actualizar ADT – recibiendo error de "dependencia en conflicto"

He tenido una serie de problemas desde que intenté importar un proyecto de android.

  1. La ubicación de mi SDK no se ha configurado en las preferencias (a pesar de que había sido antes y ADT estaba funcionando perfectamente bien).
  2. Cuando intento fijar la trayectoria a la carpeta del sdk, dice

Este SDK de Android requiere Android Developer Toolkit versión 23.0.0 o superior. La versión actual es 22.6.2.v201403212031-1085508. Actualice ADT a la última versión.

  • Así que trato de actualizar Eclipse por lo siguiente como se sugiere en otro post SO (ya que "Buscar actualizaciones" sigue diciéndome que no hay actualizaciones disponibles:
  • Ayuda -> Instalar nuevo software -> p2repo – https://dl-ssl.google.com/android/eclipse/ -> Comprobar herramientas para desarrolladores -> Siguiente Y ahí es donde me sale el siguiente error:

     Cannot complete the install because of a conflicting dependency. Software being installed: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578) Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508) Only one of the following can be installed at once: ADT CDT Integration 23.0.2.1259578 (com.android.ide.eclipse.ndk 23.0.2.1259578) ADT CDT Integration 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ndk 22.6.2.v201403212031-1085508) Cannot satisfy dependency: From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508) To: com.android.ide.eclipse.ndk.feature.group 22.6.2 Cannot satisfy dependency: From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508) To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508] Cannot satisfy dependency: From: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578) To: com.android.ide.eclipse.ndk [23.0.2.1259578] Cannot satisfy dependency: From: Android Native Development Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ndk.feature.group 22.6.2.v201403212031-1085508) To: com.android.ide.eclipse.ndk [22.6.2.v201403212031-1085508] 

    ¿Cómo puedo solucionar con éxito estos errores y actualizar eclipse?

    HOY, tengo el mismo error que tú:

    Este SDK de Android requiere Android Developer Toolkit versión 23.0.0 o superior. La versión actual es 22.6.2.v201403212031-1085508. Actualice ADT a la última versión.

    TU MENSAJE:

    Este SDK de Android requiere Android Developer Toolkit versión 23.0.0 o superior. La versión actual es 22.6.2.v201403212031-1085508. Actualice ADT a la última versión.

    Lo arreglé en 5 minutos:

    1-Asegúrese de que todavía tiene el archivo zip (me es "adt-bundle-windows-x86_64-20140321")

    2-Copia el contenido de la cremallera donde quieres que esté

    3-Es como 1,30 GB (creo), así que dependiendo de su computadora podría tomar unos minutos

    4-Una vez copiado, ábralo.

    5-Vaya a la carpeta eclipse, luego abra la aplicación eclipse (incluso puede pinearla en la barra de tareas si la usa mucho)

    Tuve este problema unas cuantas veces, y esto siempre funciona para mí.

    Simplemente desinstale la versión actual de ADT es 22.6.2.v201403212031-1085508 yendo a Ayuda> Detalles de instalación> software instalado y luego seleccione ADT (versión antigua)> haga clic en desinstalar. Ahora reinstale el ADT más reciente. De esta manera, pude actualizar ADT a la versión actual, espero que ayude. Nota: Esto no funcionará en adt-bundle.

    Desinstale todos los componentes en conflicto. En mi caso, Open-GL, DDMS, ADT etc estaban en conflicto con la actualización. Así que desinstalé todos estos, utilizando ..

    Ayuda-> Acerca de Eclipse SDK-> Detalles de la instalación-> seleccione el componente para desinstalar-> desinstalar

    A continuación, actualice su ADT.

    Ayuda-> Instalar nuevo software-> Seleccione el sitio de actualización de Adt ( https://dl-ssl.google.com/android/eclipse/, si no lo tiene, agregue) en los sitios disponibles de S / W. Y actualizar el ADT.

    Para Sanjay Manohar:

    Básicamente, cuando descargó eclipse, estaba en un archivo zip. Necesitas extraer los archivos para usar su contenido. El archivo que descargué fue nombrado "adt-bundle-windows-x86_64-20140321" y lo obtuve de " https://developer.android.com/training/basics/firstapp/index.html ".

    Si está utilizando eclipse, probablemente tenga el archivo zip en sus descargas, así que no necesita descargarlo de nuevo.

    Si yo fuera tú, haría un archivo llamado "ANDROID" y en él colocaré el archivo zip (para usarlo como una futura copia de seguridad si tienes problemas similares)

    También crearía una carpeta llamada espacio de trabajo para todos mis proyectos, y una carpeta llamada ADT en la que extraería el contenido del archivo zip.

    Esto sería las carpetas dentro de "ANDROID":

    -ADT (-> contiene los archivos extraídos del archivo zip "adt-bundle-windows-x86_64-20140321")

    -workspace (-> contiene mis proyectos)

    -adt-bundle-windows-x86_64-20140321 (-> el archivo zip)

    Lo siento por crear una nueva respuesta, no tengo la reputación …

    Simplemente seleccione ADT de las herramientas de desarrollo desplegable

  • Instalación de Android SDK en Windows 7 de 64 bits: "JDK no encontrado"?
  • ADK vs JDK vs SDK diferencia?
  • Adt eclipse bundle 02-07-2014 ACTUALIZACIÓN
  • ¿Cómo vincular a Android Marketplace Review desde dentro de la aplicación?
  • IPackageStatsObserver no se puede resolver con un tipo (Android)
  • Crear un SDK (archivo jar único) con archivos "so"
  • Soporte de Android Wear 2.0 para la aplicación de vista de reloj
  • ¿Cómo compilar un proyecto de Android en un archivo .apk en Eclipse sin iniciar el emulador?
  • Facebook SDK 7.8.0 Error: get_activeBuildTarget no puede ser llamado desde un constructor ScriptableObject
  • Ejecución del nuevo emulador de Intel para Android
  • Control de la propagación de eventos táctiles en caso de superposición de vistas
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.