Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Gradle versión 1.10 es necesario. La versión actual es 2.2.1. En android

Tenía un proyecto de Android construido con Android Studio y tratando de importar y ejecutarlo en mi Android Studio, pero frente al siguiente error al intentar sincronizar el proyecto

Failed to sync Gradle project 'project-android' Error:Gradle version 1.10 is required. Current version is 2.2.1. If using the gradle wrapper, try editing the distributionUrl in /Users/username/apps/android/project-android/gradle/wrapper/gradle-wrapper.properties to gradle-1.10-all.zip. Please fix the project's Gradle settings in Gradle settings 

Gradle-wrapper.properties

 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

Construir un gradiente

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.+' } } allprojects { repositories { mavenCentral() } } Android Studio Version : 1.0.1 

Así que cómo solucionar el error anterior

Editar

Después de cambiar las líneas según lo indicado por @Grabiele estaba consiguiendo los errores abajo

 Error:(22, 0) Gradle DSL method not found: 'runProguard()' Possible causes: The project 'project-android' may be using a version of Gradle that does not contain the method. The build file may be missing a Gradle plugin. 

Esta es la línea que tenía en el archivo app/build.gradle

  buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } 

  • Android Studio: las variantes de la generación no aparecen
  • Cómo hacer que los complementos de Hugo y AndroidDevMetrics compile sólo en depuración:
  • Android Studio sigue recibiendo una versión no soportada de major.minor 52.0
  • Agrega la API de datos de YouTube a Android Studio
  • ¿Qué comandos realiza la función `gradle-aware 'de Android Studio
  • Gradle genera para cada carpeta de recursos
  • Instruir la secuencia de comandos Gradle de Android para eliminar apks no alineados y limpiar los archivos de artefacto
  • Com.android.builder.testing.ConnectedDevice> hasTests FALLA
  • 2 Solutions collect form web for “Gradle versión 1.10 es necesario. La versión actual es 2.2.1. En android”

    Usted tiene que actualizar el:

    • Gradle plugin para Android
    • Versión gradle
    • Sintaxis proguard

    Gradle plugin para Android

    Tienes que cambiar esta línea en build.gradle :

     classpath 'com.android.tools.build:gradle:0.9.+' 

    en

     classpath 'com.android.tools.build:gradle:1.1.+' 

    Versión Gradle

    Cambiar esta línea en gradle-wrapper.properties

     distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

    en

     distributionUrl=http\://services.gradle.org/distributions/gradle-2.2.1-all.zip 

    Acerca de proguard tienes que cambiar esta línea en tu build.gradle

     buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } 

    En

     buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } 

    Además de @Gabriele respuesta

    Debes cambiar

     runProguard false 

    a

     minifyEnabled false 
    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.