Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Gradle no puede resolver la dependencia de Play Services

Tengo un proyecto Android limpio con Google Play Services rev. 13 instalado a través del gestor SDK, siguiendo estas instrucciones .

Mi archivo build.gradle es como sigue:

 dependencies { compile 'com.google.android.gms:play-services:4.0.30' } 

Sin embargo, cuando intento crear esta aplicación, obtengo

 Gradle: A problem occurred configuring project ':Maple'. > Failed to notify project evaluation listener. > Could not resolve all dependencies for configuration ':Maple:_DebugCompile'. > Could not find com.google.android.gms:play-services:4.0.30. Required by: MapleProject:Maple:unspecified 

  • Gradle - recopilación de módulos selectivos (reutilización jar de lo contrario)
  • Importar proyecto de biblioteca varias veces en Android Studio 1.3.1 hace que la biblioteca desaparezca
  • Gradle versión 1.8 es necesario. La versión actual es 1.9-rc-3 - Android Studio
  • Actualización del proyecto a Android Studio 1.0 (problemas de Gradle)
  • ¿Por qué Android Gradle preDexDebug "Origen y destino debe ser diferente" la construcción falló?
  • No se puede generar APK firmado con proguard habilitado cuando se usa Joda Time
  • Gradle: añadir dependencia para un sabor específico de la biblioteca
  • XmlPullParserException: vector de etiqueta desplegable no válido
  • 3 Solutions collect form web for “Gradle no puede resolver la dependencia de Play Services”

    Instale el repositorio de Google en el gestor de SDK.

    Incluso si ha instalado Google Repository en SDK Manager, es posible que siga viendo el mismo error.

    Otra posible solución es rebajar su versión.

    Por ejemplo, en lugar de

     compile 'com.google.android.gms:play-services:11.2.0' 

    Hacer

     compile 'com.google.android.gms:play-services:11.0.4' 

    La notificación 11.2.0 se anuncia en la página Configuración de Google Play Services de Google , pero no funciona para mí.

    ¿Está probando en Avd (emulador o dispositivo?) Si el emulador por favor compruebe a continuación: He resuelto este problema mediante la creación de un nuevo avd con la versión de destino como: API de Google (GoogleInc) API nivel 18. (plataforma 4.3 google api necesario)

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.