Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Gradle está fallando al sincronizar mi proyecto en el nuevo Android Studio 2.0

Acabo de actualizar (es decir, instaló una nueva versión completa) mi Android Studio de 1,5 a 2,0. La actualización parecía ir sin problemas, pero tengo problemas con mi proyecto cuando lo abro, cuando Gradle está sincronizando mi proyecto.

Después de la sincronización de Gradle se ejecuta por un par de minutos me sale este error:

Failed to sync Gradle project MyProject Unknown host 'jcenter.bintray.com'. You may need to adjust the proxy settings in Gradle. Error: Enable Gradle "offline mode' and sync project Learn about configuring HTTP proxies in Gradle 

Por lo tanto, hago clic en el enlace que dice:

 Enable Gradle "offline mode' and sync project 

Entonces Gradle gira por un segundo o dos, y ahora tengo este mensaje:

 Failed to sync Gradle project MyProject Error: No cached version of com.android.tools.build:gradle:1.3.0 available for offline mode. Disable Gradle 'offline mode' and sync project 

Por lo tanto, hago clic en este enlace:

 Disable Gradle 'offline mode' and sync project 

Y estoy de vuelta a mi primer error de nuevo.

La máquina en la que estoy trabajando es 100% fuera de línea. No tiene, ni tendrá nunca cualquier tipo de conexión de red en absoluto. Creo que necesito deshabilitar algún tipo de cheque que requiere Internet, pero no estoy seguro de qué. ¿Es esto fijable, o tengo que bajar de nuevo a Android Studio 1.5?

ACTUALIZAR

También recibo este mensaje de error:

 Gradle sync failed: Unknown host 'services.gradle.org'. You may need to adjust the proxy settings in Gradle. 

8 Solutions collect form web for “Gradle está fallando al sincronizar mi proyecto en el nuevo Android Studio 2.0”

Ok, arreglé mi problema por lo que quería publicar cómo lo hice en caso de que alguien más se encuentra con esta situación.

Yo estaba googleando y encontré una declaración sobre el trabajo fuera de línea con Android Studio que decía:

Puede, sin embargo, no podrá utilizar ninguna dependencia de Gradle. Gradle busca en los repositorios para las dependencias que usan Internet, así que si no puedes trabajar en línea. Trate de no incluir nada en los archivos de Gradle, si lo hace, tendrá que sincronizarlo y fallará. Bascially simplemente no tocar archivos Gradle y usted será bueno para ir.

Así que, miré mis archivos gradle, específicamente el build.gradle para el proyecto (no para el módulo). Una vez allí, noté una línea:

 dependencies { classpath 'com.android.tools.build:gradle:1.3.0' } 

Por lo tanto, he reemplazado 1.3.0 con 2.0.0 y el proyecto construido muy bien.

Espero que esto ayude a alguien más en el futuro. Buena suerte.

Tuve el mismo problema que el tuyo. Afortunadamente, logré resolverlo. Usted necesita ir a Archivo >> Configuración >> Construcción, Ejecución, Implementación >> Herramientas de Construcción >> Gradle . Necesita cambiar el hogar de Gradle . El mío era "C: / Archivos de programa / Android / Android Studio / gradle / gradle-2.08 " y dijo que la ruta no es válida. Por lo tanto, sólo vuelva a revisar su camino en su explorador de archivos y cambiarlo. Cambié el mío por "C: / Archivos de programa / Android / Android Studio / gradle / gradle-2.10 ".

Tuve un problema similar. Estaba tratando de construir una de las muestras de medios. Intenté usar gradle 2.0.0 como sugerí pero no funcionó. Me puso en el camino correcto. Gradle 2.1.0, junto con desactivar el modo sin conexión lo consiguió para trabajar.

Tengo el mismo problema cuando descargé "BackboneExampleApp" código fuente de guithub Haga clic aquí para obtener el código . He hecho el siguiente proceso viendo la configuración de mis antiguos proyectos y encontré estos errores. Resolví los dos errores, ejecutar mi aplicación y tengo errores para actualizar el proyecto y, finalmente, cuando me actualizó a continuación, no existen más problemas. Sólo ver fotos para obtener ayuda.

Introduzca aquí la descripción de la imagen

Build.gradle (Proyecto: BackboneExampleApp-master) ->

 dependencies { classpath 'com.android.tools.build:gradle:2.3.1' } 

Para aquellos que tienen problemas con el mensaje de error: Aprender a configurar la configuración de HTTP, a continuación es la solución que funcionó para mí. Estoy usando el estudio de Android 2.3.3:

Vaya a http://developer.android.com/studio/intro/studio-config.html Paso 1: Siga las instrucciones en: Configuración del proxy de estudio de Android. Paso 2: Siga las instrucciones de: Plugin de Android para la configuración de proxy HTTP gradle. Verá la configuración del proxy en: # configuración de gradle del proyecto, copie el código allí y péguelo en el espacio vacío en el archivo de propiedades gradle que está bajo el gradle de compilación en Android studio. Asegúrese de que está conectado a Internet durante este proceso. Espere hasta que desaparezca el error.

Paso 3: puede que aparezca otro mensaje emergente que indica que algunas carpetas pueden haber estado sin sincronizar ahora. Simplemente haga clic en syn ahora.

Espero que esta ayuda, gracias a todos.

Para mí fue un problema de conexión, que he comprobado mi conexión está trabajando en el mismo segundo que he habilitado y desactivado Gradle fuera de línea, a continuación, Android Studio descargar los archivos necesarios

Nota: Mi Conexión estaba desconectando y volviendo a conectar muchas veces, así que descubrí que este error fue causado por la conexión especialmente que no era el mismo tiempo que toma al intentar sincronizar mi Gradle

Me enfrenté a la misma cuestión. Asegúrese de haber realizado una entrada en path en la variable de entorno para gradle

 C:\Program Files\Android\Android Studio\gradle\gradle-3.2\bin 

Después de deshabilitar el modo sin conexión y establecer la ruta de acceso en variables de entorno, el problema se solucionó y Gradle se creó de forma limpia.

Parece que hay múltiples razones para este problema. Lo arreglé cambiando la "versión Gradle" y "versión de plugin de Android".

Puede ser útil para alguien. Vaya a Archivo-> Estructura del proyecto. Seleccione Project y actualice las versiones gradle y android plugin.

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.