Esta biblioteca de soporte no debe utilizar una versión diferente Error en build.gradle

Amigos soy principiante de la programación de Android, chicos hay un problema en mi buil.gradle Studio de Android. El error en el gradle es que (compile 'com.android.support:appcompat-v7:24.0.0-beta1') en esta línea la pantalla de error que (Esta biblioteca de soporte no debe usar una versión diferente (24) entonces la compilación sdk versión 23) alguna idea? y he usado Android Studio 2.1.2 y el principal problema es que en el estudio de Android no hay una biblioteca de soporte para Android. la foto esta abajo

introduzca la descripción de la imagen aquí

Su compileSdkVersion es 23 en el archivo build.gradle pero está intentando usar appcompat-v7: 24.0.0 que es para API 24, por lo que debería usar appcompat-v7: 23.xy para API 23. Si todavía desea use appcompat-v7: 24.0.0 entonces debe cambiar la compileSdkVersion a 24

Debe utilizar esto para compileSdkVersion 23:

compile 'com.android.support:appcompat-v7:23.4.0'

y esto para compileSdkVersion 24:

Compile 'com.android.support:appcompat-v7:24.0.0'

Sí, no deben ser diferentes. Cambiarlo para compile 'com.android.support:appcompat-v7:23.4.0'

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.