Error: el paquete javax.annotation no existe después de la actualización a lombok 1.16.2

Mi proyecto de android se basa bien con lombok 1.16.0, pero una vez que cambie mi dependencia a la meta 1.16.2, obtengo el siguiente error en todas partes que estoy usando una anotación lombok:

Error:(20, 1) error: package javax.annotation does not exist

El SDK para Android no incluye todos los paquetes javax. ¿Qué me estoy preguntando es si esto es un error en 1.16.2 o ahora tengo que agregar una dependencia a javax.annotation ?

Nota: Esto está en Android Studio con el plugin Lombok 0.8.8

    Puede desactivar la generación de javax.annotation.Generated poniendo la siguiente línea en un archivo lombok.config en uno de los directorios principales de su proyecto:

     lombok.addGeneratedAnnotation = false 

    Consulte la documentación de configuración para obtener más información.

    Divulgación: Soy un desarrollador de Lombok.

    Si usted está enfrentando el mismo problema en Android Studio usando gradle – agregue la siguiente línea a build.gradle:

     provided 'org.glassfish:javax.annotation:10.0-b28' 

    La respuesta correcta para el desarrollo de Android hoy es utilizar una versión de daga que sea mayor que 2.1 (debido a la corrección mencionada por @tomrozb está integrada en 2.1)

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.