Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Error de Android Studio FloatingActionButton

He instalado Android Studio ayer, y después de luchar contra múltiples java y otros errores, he llegado a un error que no puedo arreglar. No he añadido nada o he hecho ningún código, simplemente he empezado un nuevo proyecto y tengo este error en la vista previa por teléfono:

Problemas de procesamiento:

The following classes could not be instantiated: - android.support.design.widget.FloatingActionButton 

Seguido por un manojo de detalles de la excepción. Toda la ayuda apreciada, me estoy poniendo desesperada. También, sea específico con respuestas complicadas, ya que no soy muy astuto con esto hasta ahora.

Si se necesitan detalles de excepción:

 android.content.res.Resources$NotFoundException: Unable to find resource ID #0x1080029  at android.content.res.Resources.getResourceName(Resources.java:2235)  at android.content.res.Resources.loadDrawableForCookie(Resources.java:2602)  at android.content.res.Resources.loadDrawable(Resources.java:2540)  at android.content.res.Resources.getDrawable(Resources.java:806)  at android.content.Context.getDrawable(Context.java:458)  at android.support.v4.content.ContextCompatApi21.getDrawable(ContextCompatApi21.java:26)  at android.support.v4.content.ContextCompat.getDrawable(ContextCompat.java:321)  at android.support.v7.widget.AppCompatDrawableManager.getDrawable(AppCompatDrawableManager.java:180)  at android.support.v7.widget.TintTypedArray.getDrawableIfKnown(TintTypedArray.java:70)  at android.support.v7.widget.AppCompatImageHelper.loadFromAttributes(AppCompatImageHelper.java:39)  at android.support.v7.widget.AppCompatImageButton.<init>(AppCompatImageButton.java:65)  at android.support.design.widget.VisibilityAwareImageButton.<init>(VisibilityAwareImageButton.java:37)  at android.support.design.widget.FloatingActionButton.<init>(FloatingActionButton.java:109)  at android.support.design.widget.FloatingActionButton.<init>(FloatingActionButton.java:105)  at java.lang.reflect.Constructor.newInstance(Constructor.java:526)  at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:704)  at android.view.LayoutInflater.rInflate_Original(LayoutInflater.java:835)  at android.view.LayoutInflater_Delegate.rInflate(LayoutInflater_Delegate.java:70)  at android.view.LayoutInflater.rInflate(LayoutInflater.java:811)  at android.view.LayoutInflater.rInflateChildren(LayoutInflater.java:798)  at android.view.LayoutInflater.inflate(LayoutInflater.java:515)  at android.view.LayoutInflater.inflate(LayoutInflater.java:394) 

  • Android: activity_main no se puede resolver o no es un campo
  • ¿Por qué el atributo minHeight no funciona en WebView Android?
  • Cadena RTL hebrea de Android con valor numérico volteado
  • Android - enviar comandos HDMI CEC a TV - minix - libCEC
  • Explorador abierto de Android del servicio evitando múltiples pestañas
  • Loopj Android Async Http - onFailure no disparado
  • Android se conecta al servidor con certificado autenticado
  • Agitar dispositivo para iniciar la aplicación
  • 7 Solutions collect form web for “Error de Android Studio FloatingActionButton”

    También tengo este problema hoy,

    Comprueba tu archivo build.gradle , usas el soporte de diseño lib version 23.2, como

     compile 'com.android.support:design:23.2.0' 

    Si es así, cámbielo a la versión 23.1.0

     compile 'com.android.support:design:23.1.0' 

    A continuación, reconstruir su proyecto … parece la versión 23.2 sigue siendo buggy

    Además del cambio detallado en la respuesta de @Handrata Samsul, también tuve que hacer otro cambio en el archivo build.gradle .

    Modificar:

     compile 'com.android.support:appcompat-v7:23.2.0' 

    convertirse:

     compile 'com.android.support:appcompat-v7:23.1.0' 

    Por lo tanto, la suma de todos los cambios fue la siguiente:

     compile 'com.android.support:appcompat-v7:23.1.0' compile 'com.android.support:design:23.1.0' 

    Gracias.

    Esto funcionó para mí:

    He cambiado en el archivo build.gradle .

    compile 'com.android.support:design:23.2.0'

    a

    compile 'com.android.support:design:23.1.0'

    A continuación, limpiar, reconstruir y, a continuación, "actualizar" cada archivo de diseño. El botón de actualización en la parte superior derecha del editor de diseño.

    Ese error aparece si ocurre alguna de las siguientes cosas:

    1. No tiene instaladas las últimas versiones de SDK. Asegúrese de tener las versiones correctas. Necesitas tener instalado Android M para usar el botón de acción flotante. (Utilice el instalador de Android SDK)

    2. Sus dependencias de gradle son incorrectas.

    Si eres nuevo en Android Studios, lo más probable es que el problema sea 1 y 2.

    Para la 2 ª edición, vaya a su archivo gradle y poner esto en:

     dependencies { compile 'com.android.support:design:23.0.0' } 

    Eso debería solucionar el problema.

    ¿Puede esto cambiarse para que los nuevos proyectos tomen las nuevas dependencias en vez de tener que cambiar el build.gradle en cada nuevo proyecto?

    Android.content.res.Resources $ NotFoundException: No se puede encontrar el recurso ID # 0x1080029

    Esta excepción es lanzada por las API de recursos cuando no se puede encontrar un recurso solicitado.

    Debe utilizar una versión estable. Puede comenzar a utilizar la biblioteca de diseño con una nueva dependencia con:

    Hacer

     compile 'com.android.support:design:23.1.0' 

    A continuación, Clean-Rebuild-Sync su IDE. Espero que esto ayude.

    No

     compile 'com.android.support:design:23.2.0' 

    La versión 23.2.0 es buggy. No es estable. Usted debe ir para el establo encima de la versión 23.1.0 .

    También actualiza la versión gradle que estás usando para compilar, por ejemplo, 2.13 en lugar de 2.9 / 2.10 que falla con libs de soporte más alto usualmente

    Más fácil es a una tarea gradle en su build.gradle principal:

     task wrapper(type: Wrapper) { gradleVersion = '2.13' } 

    Y luego ejecutarlo con

     gradle wrapper 
    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.