Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Error de 25.0.0 durante la compilación del proyecto

Tengo un proyecto que estaba funcionando bien hasta la fecha. De repente hoy frente a estos problemas:

Error:A problem occurred configuring project ':app'. > Could not resolve all dependencies for configuration ':app:_debugCompile'. > Could not find com.android.support:appcompat-v7:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar Required by: Yokura-Seeker:app:unspecified Yokura-Seeker:app:unspecified > com.android.support:design:23.4.0 > Could not find com.android.support:cardview-v7:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar Required by: Yokura-Seeker:app:unspecified > Could not find com.android.support:support-v4:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar Required by: Yokura-Seeker:app:unspecified > com.android.support:design:23.4.0 Yokura-Seeker:app:unspecified > com.android.support:recyclerview-v7:23.4.0 > Could not find com.android.support:support-v4:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar Required by: Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0 > Could not find com.android.support:appcompat-v7:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/appcompat-v7/25.0.0/appcompat-v7-25.0.0.jar Required by: Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0 > Could not find com.android.support:cardview-v7:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom https://jcenter.bintray.com/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/cardview-v7/25.0.0/cardview-v7-25.0.0.jar Required by: Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0 > Could not find com.android.support:customtabs:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar https://jcenter.bintray.com/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom https://jcenter.bintray.com/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/customtabs/25.0.0/customtabs-25.0.0.jar Required by: Yokura-Seeker:app:unspecified > com.facebook.android:facebook-android-sdk:4.17.0 > Could not find com.android.support:support-v4:25.0.0. Searched in the following locations: file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/Android Studio/Android Studio/gradle/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom https://jcenter.bintray.com/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom https://repo1.maven.org/maven2/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/android/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.pom file:/D:/NewEclips/android-sdk-windows/extras/google/m2repository/com/android/support/support-v4/25.0.0/support-v4-25.0.0.jar Required by: Yokura-Seeker:app:unspecified > com.google.android.gms:play-services-auth:9.8.0 > com.google.android.gms:play-services-basement:9.8.0 

Tampoco tengo 25.0.0 en mi sdk, havnt todavía lo ha descargado, y también mi versión de compilación es 23.0.2 entonces ¿y está buscando 25.0.0?

EDIT:

El problema exacto que estoy enfrentando ahora es que estoy usando

 compile 'com.facebook.android:facebook-android-sdk:4.+' 

En gradle para facebook.

Y en esta biblioteca está utilizando 25.0.0 así que ¿cómo evitar eso?

3 Solutions collect form web for “Error de 25.0.0 durante la compilación del proyecto”

Ya que no especificó la versión exacta de facebook SDK: compile 'com.facebook.android:facebook-android-sdk:4.+' , utiliza cualquier versión (probablemente la última), que probablemente apunte al último SDK (25), Y requiere las últimas versiones de la biblioteca de soporte.
Así que tienes 2 maneras de solucionarlo:

  1. Instalar las bibliotecas que faltan y, probablemente, el SDK 25 en su proyecto
  2. Utilizar alguna versión exacta de SDK de Facebook, que no apunta a los últimos SDK de Android

Acaba de reemplazar la versión de compilación de Facebook, porque en la última versión de soporte de lib se actualiza a la versión 25 de SDK.
Compile 'com.facebook.android:facebook-android-sdk:4.16.1'
Sólo tienes que ir a este enlace para comprobar los registros de cambios de SDK
https://developers.facebook.com/docs/android/change-log-4.x

TL; DR Sólo instale la API 25 y actualice todo en SDK Manager.

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.