Error: archivos duplicados durante el empaquetado de APK Android Studio Error

Estoy recibiendo un error inesperado en el estudio de Android durante la ejecución de la aplicación, a continuación se muestra el mensaje de error que estoy recibiendo

Error: archivos duplicados durante el empaque de APK /home/jithu/libs/android/android/aa/app/build/outputs/apk/app-debug-unaligned.apk Ruta en archivo: META-INF / DEPENDENCIES Origen 1: / home /jithu/.gradle/caches/modules-2/files-2.1/org.apache.httpcomponents/httpmime/4.3.6/cf8bacbf0d476c7f2221f861269365b66447f7ec/httpmime-4.3.6.jar Origen 2: /home/jithu/.gradle/caches/ modules-2 / files-2.1 / org.apache.httpcomponents / httpcore / 4.4.1 / f5aa318bda4c6c8d688c9d00b90681dcd82ce636 / httpcore-4.4.1.jar

Estoy pegando mi archivo build.gradle también

apply plugin: 'com.android.library' android { compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { minSdkVersion 14 targetSdkVersion 21 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile 'com.android.support:appcompat-v7:+' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.squareup.picasso:picasso:2.5.2' compile 'com.mcxiaoke.volley:library:1.0.15' compile 'com.google.code.gson:gson:2.2.4' compile "org.apache.httpcomponents:httpcore:4.4.1" compile "org.apache.httpcomponents:httpmime:4.3.6" } android { packagingOptions { exclude 'META-INF/DEPENDENCIES' exclude 'META-INF/NOTICE' exclude 'META-INF/LICENSE' exclude 'META-INF/LICENSE.txt' exclude 'META-INF/NOTICE.txt' } // ... } 

Bueno, te estás perdiendo el flujo de gradle de construcción. Como estás intentando usar 2 snippet android {..} no está detectando el segundo. Como resultado, su exclusión de archivos meta duplicados no funciona.

Solución posible:

Simplemente cambie el orden de su gradle de construcción como a continuación:

  apply plugin: 'com.android.library' android { compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { minSdkVersion 14 targetSdkVersion 21 versionCode 1 versionName "1.0" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } packagingOptions { exclude 'META-INF/DEPENDENCIES' exclude 'META-INF/NOTICE' exclude 'META-INF/LICENSE' exclude 'META-INF/LICENSE.txt' exclude 'META-INF/NOTICE.txt' } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') compile 'com.android.support:appcompat-v7:+' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.squareup.picasso:picasso:2.5.2' compile 'com.mcxiaoke.volley:library:1.0.15' compile 'com.google.code.gson:gson:2.2.4' compile "org.apache.httpcomponents:httpcore:4.4.1" compile "org.apache.httpcomponents:httpmime:4.3.6" } 

Si todavía no funcionó, echa un vistazo a lo siguiente:

¿Es su gradle de la construcción de la biblioteca? He excluido mis archivos duplicados meta de mis proyectos principales build gradle. Por lo tanto, asegúrese de excluir los archivos meta del gradle de compilación de módulo de aplicación en lugar de módulo de biblioteca.

  • No se pueden serializar las fechas con ksoap2
  • Retrofit 2.0 cómo imprimir la respuesta json completa?
  • Desafortunadamente MyApp se ha detenido. ¿Como puedo resolver esto?
  • OnConfigurationChanged () no se dispara para keyboardHidden
  • Detectar la actualización de la aplicación de Android y establecer la clase de aplicación booleana para mostrar / ocultar el CLUF
  • No se puede resolver el destino 'android-21'
  • Cómo actualizar fragmento anterior después de cerrar una actividad que se inició dentro de un adaptador?
  • No se puede resolver ContextCompat en Android
  • ¿Por qué se genera un error al declarar una clase anidada de Fragmento estático como privada?
  • Last.fm no devolverá la imagen del artista
  • Juego de desplazamiento lateral de Java en android
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.