Error al resolver la biblioteca de bloqueos de Firebase android 'com.google.firebase: firebase-core: 11.0.2'

Estoy intentando actualizar mis dependencias para compilar 'com.google.firebase: firebase-core: 11.0.2' pero

Todo lo que obtengo es:

Failed to resolve: com.google.firebase:firebase-core:11.0.2' 

¿Cuál podría ser la razón?

La instalación de la última versión del repositorio de Google ayudará.

  1. Vaya a la barra de menús> Herramientas> Android> SDK Manager
  2. Haga clic en Tab> SDK Tools
  3. Compruebe e instale "Servicios de Google Play" y "Repositorio de Google"
  4. Ahora, haga clic en Sincronizar y vuelva a generar su proyecto.
  • Error de generación de token Google Cloud Messaging (GCM) después de la actualización de Google Play Services relacionada con Firebase
  • ¿Por qué el límite de frecuencia de anuncios de AdMob no funciona?
  • El inicio de la aplicación se ralentiza: No se puede abrir '/system/framework/dpmapi.jar'
  • Integre firebase auth con los puntos finales de la nube de motores de aplicaciones de Google
  • Cambiar dinámicamente el límite de una referencia de consulta de Firebase en Android
  • "FirebaseError: Se proporcionan credenciales de autenticación no válidas" al configurar el inicio de sesión de Google en Android
  • Escribir datos en firebase a través de una aplicación android
  • Google Play Games, Firebase y el nuevo inicio de sesión de Google
  • Restringir las notificaciones de GCM / FCM mediante la cancelación de registro
  • No puedo añadir firebase a la aplicación de Android
  • Clave de la API de mensajería en la nube de Firebase
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.