Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Error al resolver 'com.google.firebase: firebase-messaging: 11.0.4' en Android Studio 2.3.3

Quiero configurar una aplicación de cliente Cloud Messaging Cloud Firebase en el estudio de Android, estoy usando la última versión de Android Studio (2.3.3) y mi androide SDK está completamente actualizado.

Aquí está mi proyecto de archivo gradle:

buildscript { repositories { jcenter() } dependencies { classpath 'com.google.gms:google-services:3.1.0' classpath 'com.android.tools.build:gradle:2.3.3' } } allprojects { repositories { jcenter() maven { url "https://maven.google.com" } } } task clean(type: Delete) { delete rootProject.buildDir } 

Y este es mi aplicación de compilación de archivo gradle:

 apply plugin: 'com.android.application' android { compileSdkVersion 25 buildToolsVersion "25.0.3" defaultConfig { applicationId "ir.digiwindow.driver.gps_status" minSdkVersion 14 targetSdkVersion 25 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile 'com.android.support:appcompat-v7:25.3.1' compile 'com.android.support.constraint:constraint-layout:1.0.0-alpha7' testCompile 'junit:junit:4.12' compile 'com.google.firebase:firebase-messaging:11.0.4' } apply plugin: 'com.google.gms.google-services' 

Y siempre doy este error:

 Error:(30, 13) Failed to resolve: compile 'com.google.firebase:firebase-messaging:11.0.4' 

El punto de intresting aquí es que cuando cambio la versión de 11.0.4 a 10.0.1 no se produce error y gradle construir con éxito! He leído todos los mensajes realated en stackoverflow y google sitio de desarrolladores, pero este error sigue existiendo! Cualquier idea bienvenida …

Editar 1: cuando vaya a buscar actualizaciones, no veo ninguna opción sobre la actualización del servicio de Google Play aquí en la imagen: introduzca la descripción de la imagen aquí

4 Solutions collect form web for “Error al resolver 'com.google.firebase: firebase-messaging: 11.0.4' en Android Studio 2.3.3”

He enfrentado el mismo problema, he resuelto actualizar cosas de remolque

  1. Servicio de reproducción de Google
  2. Repositorio de Google

Introduzca aquí la descripción de la imagen

Sr. Jan,

Por favor, siga el enlace a continuación su claramente dice que–

Un dispositivo con Android 4.0 (Ice Cream Sandwich) o más reciente, y los servicios de Google Play 11.0.4 o superior

https://firebase.google.com/docs/android/setup#Prerequisites

Por favor, actualice sus servicios de google play y el repositorio de Google en el gestor de SDK como debajo del paso

Abra el estudio de Android> Vaya a Archivo> Configuración> Aspecto y comportamiento> Configuración del sistema> SDK de Android> Herramientas de SDK> Actualizar los servicios de reproducción de Google y el repositorio de Google bajo el repositorio del sistema

Como Dileep mencionó en la documentación, debe tener instalados Google Play Services 11.0.4 o superior.

Sólo tienes que abrir el SDK Manager,
Luego Android SDK (en el menú de la izquierda)
A continuación, en la ficha Herramientas del SDK y actualiza Google Play Services, que se encuentra actualmente en la versión 43 (2017-08-10).

Eso me lo resolvió.

Tuve el mismo problema y sólo cambiar la versión 11: 0: 4 a 10: 0: 1 y el error desaparecido. Sólo probarlo, tal vez útil.

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.