Error al resolver: com.android.support:appcompat-v7:15.+

Encontré 2 soluciones para este problema, pero ambos no funcionaron. Así que decidí preguntarte.

Estoy usando Debian 8 Jessie y Android Studio 1.4

Acabo de crear el nuevo proyecto y cuando intenté comenzarlo conseguí un error: "No pudo resolver: com.android.support:appcompat-v7:15.+" Y me da la opción 3.

1) Instalar el repositorio y sincronizar el proyecto

Cuando lo intenté, recibí un error como este:

Loading SDK information... Ignoring unknown package filter 'extra-android-m2repository'Warning: The package filter removed all packages. There is nothing to install. Please consider trying to update again without a package filter. 

Y abajo de la ventana:

 Install failed. Please check your network connection and try again. You may continue with creating your project, but it will not complete correctly without the missing components. 

2) Mostrar en archivo

Es mis dependencias de build.gradle:

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) testCompile 'junit:junit:4.12' compile 'com.android.support:appcompat-v7:15.+' } 

Error en esta línea:

 compile 'com.android.support:appcompat-v7:15.+' 

3) Mostrar diálogo de estructura de proyecto

Las ventanas de las dependencias se abren y alrededor de esta línea otra vez:

 compile 'com.android.support:appcompat-v7:15.+' 

Soluciones probadas:

En primer lugar, traté de descargar la versión sdk de nuevo. He eliminado Android 4.0.3 y volver a descargar de nuevo, pero sigue siendo el mismo error.

Después de que he intentado descargar la biblioteca de soporte que se recomienda en; Tema 1 , tema 2 . Después de descargar Android Support Library, rev 23.0.1 todavía tiene el mismo error.

Después de que traté de resolver mi problema con la fijación de la primera opción en error (instalar el repositorio y el proyecto de sincronización.Y he encontrado algunos temas de nuevo.Revisé mi sección de proxy HTTP en Configuración, ya está seleccionado "No proxy".

Así que, he intentado todo lo que encontré, pero aún así tengo este error. Alguien puede ayudarme por favor?

7 Solutions collect form web for “Error al resolver: com.android.support:appcompat-v7:15.+”

Después de descargar la última biblioteca de soporte con su gestor sdk, puede establecer esa versión en su archivo gradle.

Si descargaste 23.0.1 establecelo así:

 compile 'com.android.support:appcompat-v7:23.0.1' 

EDIT : También tenga en cuenta la siguiente sugerencia, dada por Android Studio, al usar + en Número de versión:

Evite usar + en los números de versión; Puede producir compilaciones impredecibles e irrepetibles (com.android.support:appcompat-v7:23.1.+)

El uso de + en dependencias le permite seleccionar automáticamente la última versión disponible en lugar de una versión específica. Sin embargo, esto no es recomendable; Sus compilaciones no son repetibles; Es posible que haya probado con una versión ligeramente diferente de lo que utilizó el servidor de compilación. (Usar una versión dinámica como el número de versión principal es más problemático que usarlo en la posición de versión secundaria.)

Editar build.gradle

Reemplace 'com.android.support:appcompat-v7:15.+' por 'com.android.support:appcompat-v7:18.0.0'

Sincronizarlo

Puede que esto te ayude. Si en caso de que esto no funcione, es decir, muéstrele un error, consulte la instalación de app-compat en "% homepath% \ AppData \ Local \ Android \ sdk \ extras \ android \ m2repository \ com \ android \ support \ appcompat-v7"

Busque la versión más antigua y coloque el número de versión en xx: 'com.android.support:appcompat-v7: xx '

He instalado Java y Android Studio hoy.

Al crear mi primer proyecto con API nivel 15 como minSDK, me enfrenté al mismo problema.

Por lo que puedo decir, parece que la instalación de la sdk funciona no muy bien. Para mí, el API de nivel 15 sólo tenía la plataforma SDK. API nivel 23 tenía plataforma y fuentes. No recuerdo, que herramientas donde instalado.

Para solucionar el problema, empecé con el gestor de sdk (versión antigua), eliminé api nivel 15 completamente e instalé api nivel 23 como se sugirió. Después de eso, un proyecto recién creado (de nuevo con minSDK 15) fue creado correctamente.

La diferencia en el archivo app/build.gradle es obvia.

Tal vez esto ayude a otras personas que enfrentan los mismos problemas, o uno de los gurús puede explicar más, lo que sucedió.

Saludos cordiales

Tienes los mismos errores.

Mac OS X

V. 10.9.5

Android studio 1.4.1

App:

Antes: android {compileSdkVersion 15 buildToolsVersion "19.1.0"

Después: android {compileSdkVersion 23 buildToolsVersion "19.1.0"

Antes: dependencies {compilar fileTree (dir: 'libs', include: ['* .jar']) testCompile 'junit: junit: 4.12' compilar 'com.android.support:appcompat-v7:15.+'}

Después: dependencies {compilar fileTree (dir: 'libs', include: ['* .jar']) testCompile 'junit: junit: 4.12' compilar 'com.android.support:appcompat-v7:23.1.o'}

Por encima de los cambios + Build >> Clean Project.

¡Espero que ayude!

Vaya a la pestaña Construida seleccione "Editar tipos construidos" seleccione la ficha de propiedades y compruebe la versión de la herramienta construida que era 19.1.1 para mí.
Luego vaya a build.gradle change compile a 'com.android.support:appcompat-v7:19+'. Cambié a 19+ porque mi versión construida es 19.1.1; Usted tiene que seleccionar de acuerdo a su versión construida (18 +, 19 +, 20 + como eso).

Pruebe la siguiente solución:

En el estudio de Android: Vaya a Archivo -> Estructura del proyecto Compruebe la versión de herramientas de compilación seleccionada.

Actualice su build.gradle para la aplicación con la versión seleccionada de las herramientas de la estructura. Por ejemplo 19.1.0

Después de la actualización, Ejecutar limpio.

Consulte la siguiente captura de pantalla. Estructura del proyecto-> Tipos de herramientas de construcción

http://i.stack.imgur.com/U1Y4D.png

Tuve un mensaje de error similar al crear un proyecto.

No puede resolver com.android.support:appcompat-v7:14.+

Observo que si creo un nuevo proyecto con soporte para 4.0.3 en lugar de 4.0, no se produce ningún error. Estoy usando android studio 1.5. Espero que esto ayude.

  • La etiqueta de registro puede tener como máximo 23 caracteres
  • Módulo de la biblioteca de Java de Android Studio vs. Módulo de la biblioteca de Android
  • Cambio de nombre de módulos en Android Studio?
  • El estudio de Android evita que el código se vuelva a formatear en la pasta
  • Error de AdMob (Error al inflar la clase com.google.ads.AdView)
  • Android Studio 1.2 - Codificaciones de codificación de proyecto por defecto
  • ¿Cuál es el papel de content_main.xml en android studio 1.4?
  • Google Play Services hace que el apk sea demasiado grande
  • Ver base de datos SQLite en el dispositivo en Android Studio
  • ¿El tamaño del texto no se cambia para los diferentes diseños de pantalla?
  • Com.android.build.transform.api.TransformException con los servicios de google play de android
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.