Error al intentar ejecutar la aplicación de Android en el emulador con phonegap, ¿cómo puedo solucionarlo?

Tengo phonegap 3.0.0-0.14.3 instalado en Ubuntu 12.04.

Quiero ejecutar la aplicación con el emulador de Android. Cuando ejecuto phonegap run android consigo lo siguiente:

 [phonegap] compiling Android... [phonegap] successfully compiled Android app [phonegap] trying to install app onto device [phonegap] no device was found [phonegap] trying to install app onto emulator [error] An error occurred while emulating/deploying the android project.Warning : [ --debug | --release | --nobuild ] not specified, defaulting to --debug Cleaning project... 

La aplicación se ejecuta en un dispositivo sin problemas.

¡Por favor ayuda!

3 Solutions collect form web for “Error al intentar ejecutar la aplicación de Android en el emulador con phonegap, ¿cómo puedo solucionarlo?”

Finalmente encontré una respuesta a mi pregunta.

Estaba recibiendo este error porque no había creado un dispositivo virtual de Android. Después de haber creado uno, todo funcionó normalmente.

En el símbolo del sistema simplemente escriba: android avd para mostrar la ventana de AVD Manager, entonces usted puede crear un dispositivo virtual android.

Espero que esto sea útil para alguien.

En la nueva versión, el adb se mueve a una nueva carpeta en mi entorno: D: \ Android \ android-sdk \ platform-tools. Así que necesitas incluir esta nueva ubicación en el camino.

Estoy usando Cordova sobre MacOSX. Usted debe intentar algo como:

 sudo android create avd --name myCordova --target 1 --abi default/armeabi-v7a --force 

en lugar de:

 android create avd --name myCordova --target 1 --abi default/armeabi-v7a --force 

Esto funciona para mi

  • Android, configuración de un entorno de compilación de Linux, libgl1-mesa-glx: paquete i386 tiene dependencias no satisfechas
  • Linux Ubuntu Android SDK manager no está iniciando - android: java: no encontrado
  • No se pudo encontrar la clase 'android.webkit.WebResourceResponse' cuando se ejecuta HelloCordova en Android 2.2
  • Gradle no puede eliminar directorio debido a .fuse_hidden
  • IntelliJ Idea 12 + Android + Scala hoy en día
  • ¿Cómo instalar Android Studio en Ubuntu?
  • Libz.so.1: no se puede abrir archivo de objeto compartido
  • Cordova ubuntu: Se ha producido un error al enumerar los objetivos de Android
  • Android Emulator no funciona en Ubuntu después de actualizar Android Studio a 2.0 - Biblioteca Qt no encontrada
  • Crear script en Córdoba falla con error inesperado en Ubuntu 12.10
  • Emulador ya está en ejecución pero no puede verlo en ubuntu
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.