Eclipse incorrectamente alegando que tengo viejo Rev de SDK de Android

Sólo para preámbulo esto he buscado alto y bajo en el Internet tratando de encontrar una respuesta a este problema y todavía tengo que encontrar uno, ha habido personas con problemas similares como yo, pero no exactamente lo mismo.

He estado intentando configurar Eclipse con el SDK de Android. Instalé primero Eclipse (Classic) y edité el archivo .ini para encontrar el archivo javaw.exe correcto. He probado eclipse y estaba funcionando bien. Luego he descargado el paquete sdk de Android extraído y utilizado el gestor de SDK para descargar las herramientas de SDK necesarias (Rev. 21) y la API de 2,33 de Android. Después de terminar eso, volví a Eclipse, hice clic en "Instalar nuevo software" y en el campo "Trabajar con" escribió "https://dl-ssl.google.com/android/eclipse/". Desde allí instalé las herramientas de desarrollo y los complementos NDK y luego cuando terminé de reiniciar Eclipse.

Ahora, cuando inicio Eclipse, obtengo el siguiente error: "Esta versión de ADT requiere Android SDK Tools revisión 21.0.0 rc9 o superior La versión actual es 11.0.0 Por favor, actualice sus herramientas de SDK a la última versión"

Sé que de hecho tengo rev 21, lo dijo cuando lo descargé y cuando intento entrar y actualizar cualquier cosa, ya sea a través de Eclipse o a través del administrador dice que no hay actualizaciones disponibles. Sé que tengo lo último de SDK y ADT y también he intentado usar la versión de eclipse que vino con el sdk pero que me da el mismo problema. Las únicas otras cosas que parecen poner las banderas rojas a mí son 1. Cuando el programa carga demuestra el mensaje siguiente en la consola "[2012-12-01 18:31:48 – Dex Loader] SecurityException: No puede encontrar el campo para dex.jar "2. Cuando intento abrir el gestor SDK a través de eclipse nunca se abre y la consola muestra el siguiente mensaje" [2012-12-01 18:37:07 – SDK Manager] [SDK Manager] Error: esperado verbo después de los parámetros globales, pero encontró 'sdk' en su lugar. "

No sé si alguno de esos dos tiene algo que ver con lo que está causando este problema, pero espero que alguien sepa lo que está pasando. Si alguien pudiera ayudarme a entender esto, lo agradecería mucho, gracias de antemano.

(Por motivos de referencia, he estado siguiendo las instrucciones de instalación de este tutorial http://youtu.be/31cxmLN09ss )

Cuando esté en el gestor de paquetes de SDK, pruebe a seleccionar el menú Paquetes -> Volver a cargar. A continuación, debe ver Android SDK Tools rev21 disponible y listo para actualizarse.

Yo tuve el mismo problema. se produjo porque una vez cuando estaba tratando de instalar el plugin de adt pocos meses antes, la ubicación se había guardado. He supervisado la ubicación de la carpeta de edad, lo confundió con la actualización actual y bam! esa fue toda la razón. intente revisar la ubicación de la carpeta de herramientas especificada.

Como seguimiento a mi sugerencia anterior, mejor solución es modificar su ubicación sdk en Windows-> Preferencias-> Android a donde instalar su paquete ADT. Por ejemplo, si instala su ADT Bundle bajo C: \ Tools \ adt-bundle-windows-x86-20130219, escriba C: \ Tools \ adt-bundle-windows-x86-20130219 \ sdk.

Hacer esto también corrige otro problema con "Android SDK Manager" que no se inicia desde Eclipse discutido en otro hilo.

Resolví el problema con Eclipse reportando que tengo un sdk más antiguo aunque tengo la última versión instalada copiando la versión correcta de sdk en "C: \ Archivos de programa \ Android \ android-sdk". Primero guarde "C: \ Archivos de programa \ Android \ android-sdk \ sdk" existentes para decir "C: \ Archivos de programa \ Android \ android-sdk \ sdk_old", en caso de que necesite revertirlo.

Esto (arriba) es un buen consejo: sin embargo, fui en eclipse y redefinió la ubicación android sdk que aparentemente estaba en una carpeta androide diferente por cualquier razón que tenía archivos obsoletos en él y creo que ahora la situación es fija Lo probé y funcionó para mí también. Gracias.

  • Administrador SDK de Android no instala componentes
  • Cómo obtener el cumpleaños de usuario de facebook sdk?
  • "IncludeAntRuntime" no se ha establecido para android ant script?
  • La aplicación de Android con Facebook no funciona con la aplicación de Facebook instalada
  • Cómo obtener la versión SDK de Android de un dispositivo desde la línea de comandos
  • Eclipse se comporta de manera diferente al crear un nuevo proyecto / actividad
  • ¿Cómo obtener la API de Kakaotalk para la aplicación de Android?
  • Fallo Android Studio
  • Android NDK: compilación personalizada de WebView desde el origen
  • Cuál es el papel de la clave de la aplicación y la clave secreta en cada SDK
  • Android SDK Bundle no se puede descargar dice "Unknown Network Error"
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.