Eclipse con plugin de Android – Bloqueado en "cálculo de requisitos y dependencias"

Tengo un problema durante la instalación de Android en Eclipse (Indigo y Helios, he probado muchas versiones diferentes). Cuando busco el complemento con la dirección http://dl-ssl.google.com/android/eclipse/ , o localy (con el archivo), no funciona.

Encontró las herramientas de desarrollo, pero bloqueó en "cálculo de requisitos y dependencias".

Cuál es el problema ?

9 Solutions collect form web for “Eclipse con plugin de Android – Bloqueado en "cálculo de requisitos y dependencias"”

Tenía exactamente el mismo problema, eclipse estaba atascado en "calcular los requisitos y dependencias" para las edades. Busqué en la web y encontré un montón de soluciones, pero ninguno funcionó para mí. Así que arrancé en modo seguro con la red (presione F8) y luego comenzó eclipse. Se instaló en 2 minutos. Mi antivirus de AVG bloqueaba el acceso de eclipse a Internet. Espero que funcione para usted también

Si está instalando desde un sitio local, desactive la opción "Contactar todos los sitios de actualización durante la instalación para encontrar el software necesario" .

Tuve el mismo problema con win 7 x64 y cualquier versión de Eclipse. Es porque no puede conectarse a Internet, a veces es sólo porque su firewall bloquea su acceso a Internet. Pero lo más probable es que, si no es así, debes ir a tus preferencias de Eclipse, General -> Conexiones de red -> elegir Direct de menú desplegable => todo debe estar desmarcado ahora. Fue lo único que me ayudó en Win 7 x64. No tengo estos problemas en Win XP.

Sus causas por estas dos razones …

  1. Su antivirus no está creando eclipse para descargar los datos requeridos.
  2. O su firewall no le permite acceder al servidor de descarga.

Solución:

  1. Simplemente abra su panel de antivirus "deje de funcionar hasta que los datos no estén instalados".
  2. Y si la primera no funciona, a continuación, abra la configuración del firewall y hacerlo hasta que los datos no se instala …

Tuve el mismo problema, y ​​lo soluciono. Vamos a ver la siguiente lista.

  1. Eclipse ha sido bloqueado por tu programa antivirus o firewall

  2. Si ha marcado, entonces el elemento 'contacto con todos los sitios de actualización' de UNCHECK … '.

    Por favor, haga clic en el botón de imagen y remítase. (Marcado con la línea roja).

Introduzca aquí la descripción de la imagen

Esto sucedió cuando intenté instalar una actualización después de que uno de los sitios de actualización que había añadido a mi instalación de Eclipse se hubiese desvanecido (el proveedor de complementos cambió las URL para acceder a su sitio de actualización).

Si se debe a un sitio de actualización inactivo, a menudo se puede resolver desmarcando "ponerse en contacto con todos los sitios de actualización durante la instalación para encontrar el software necesario".

Si sabe qué sitio de actualización está causando el problema y desea eliminarlo / deshabilitarlo, o si necesita acceso a otros sitios de actualización durante la instalación, puede deshabilitar temporalmente o quitar permanentemente sitios de actualización de Preferencias-> Instalar / Actualizar-> Sitios de software disponibles.

Tuve el mismo problema en mi Ubuntu. Supongo que puedes resolver tu problema de la siguiente manera:

Cargar Eclipse. Haga clic en Help > Install new software > Add y, a continuación, en v3.7.x en el cuadro de nombre, ingrese Indigo y, en el cuadro URL, ingrese http://download.eclipse.org/releases/indigo y siga las instrucciones para instalar el archivo. ADT plug-in y funcionará.

Si está utilizando otras versiones de Eclipse necesita cambiar el nombre y la url a lo siguiente:

 v3.7.x Indigo - http://download.eclipse.org/releases/indigo v3.6.x Helios - http://download.eclipse.org/releases/helios 

Tuve un problema similar al intentar instalar un plugin de Eclipse – ShellEd. Se quedó atascado en el mismo punto. Como señala el problema de la red, simplemente desactivado mi conexión WiFi durante la instalación de un archivo descargado y la instalación se hace.

O simplemente salir / relanzar eclipse, intentar actualizarlo, jugar con él hasta que eventualmente instalará ADT

  • Ejecutar GTM diagnosticar error
  • Incluir proyecto Java como biblioteca
  • Android + Eclipse: Cómo limpiar / restablecer un AVD
  • Cómo implementar y usar google cloud sql en mi aplicación android (eclipse)
  • Error de Android al agregar un spinnerSelector, ningún identificador de recurso encontrado
  • Representación de mapa de bits de Eclipse en el depurador
  • No se puede crear un ToggleButton en Eclipse IDE para android
  • No puede encontrar annotations.jar después de actualizar a ADT 23
  • Cómo modificar el nombre de versión en Manifiesto durante la generación?
  • Android 8 o superior: comprobar los servicios de Google Play
  • Compartir un espacio de trabajo Eclipse entre Linux y Windows
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.