Dependencias -> No se pudo crear el complemento del tipo 'AppPlugin'

Estoy tratando de seguir trabajando en un proyecto más antiguo mío, es de alrededor de un año de edad, y estaba funcionando bien en ese entonces, pero ahora después de que he actualizado AndroidStudio, ni siquiera puede construir más.

Estoy recibiendo un error diciendo que tengo el mismo archivo dex dos veces:

com.android.dex.DexException: Multiple dex files define Landroid/support/v4/accessibilityservice/AccessibilityServiceInfoCompat$AccessibilityServiceInfoVersionImpl; 

Para arreglar esto, podría simplemente hacer "gradle dependencias" para encontrar el culpable, y excluir los archivos defectuosos, pero aquí es donde me encuentro con mi problema real.
Cuando hago "gradle dependencies", consigo el error siguiente:

 FAILURE: Build failed with an exception. * Where: Build file 'F:\Github\Coinbook\app\build.gradle' line: 1 * What went wrong: A problem occurred evaluating project ':app'. > Could not create plugin of type 'AppPlugin'. * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. 

Y aquí está mi archivo build.gradle completo:

 apply plugin: 'com.android.application' android { compileSdkVersion 21 buildToolsVersion "21.1.2" defaultConfig { applicationId "com.moonrain.coinbook" minSdkVersion 14 targetSdkVersion 21 versionCode 1 versionName "0.7" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile project(':libs:AndroidBootstrap') compile files('libs/socialauth-4.4.jar') compile files('libs/socialauth-android-3.2.jar') compile 'com.doomonafireball.betterpickers:library:1.5.2' compile 'com.jakewharton:butterknife:6.0.0' compile 'com.astuetz:pagerslidingtabstrip:1.0.1' compile 'com.github.castorflex.smoothprogressbar:library:1.0.0' compile 'com.squareup.picasso:picasso:2.3.4' compile 'com.readystatesoftware.systembartint:systembartint:1.0.4' compile 'com.google.code.gson:gson:2.3' } 

Así que esto es que estoy básicamente atrapado en este momento, he intentado lo siguiente para solucionar el problema:
– Actualización de AndroidStudio
– Actualización de todos los elementos relacionados con SDK
– Actualizado gradle
– Re-creado el proyecto completo en una nueva carpeta, luego copiado sobre mis archivos en el nuevo proyecto

Cada post que encuentro con respecto a este tema, dice que use Gradle 0.7.3 En lugar de 0.7.2 Debido a un error .. Pero eso es como un año de edad, y ya no es válido.

One Solution collect form web for “Dependencias -> No se pudo crear el complemento del tipo 'AppPlugin'”

Intente cambiar la versión gradle en gradle / wrapper / gradle-wrapper.properties

  distributionUrl=http\://services.gradle.org/distributions/gradle-1.12-all.zip 

A algo como

  distributionUrl=http\://services.gradle.org/distributions/gradle-2.2.1-all.zip 
  • Importar biblioteca en Eclipse sin jar
  • AndroidManifest.xml para Gradle instrumentTest
  • Error de ADT que exporta con Gradle
  • ¿Qué hacer con los archivos .rawproto en el directorio de compilación de Android Studio?
  • Cómo incluir dependencias de maven remoto en una biblioteca de Android
  • Crouton depende de las bibliotecas, pero no es una biblioteca en sí
  • Gradle excluir plugin en proyecto principal para subproyecto (s) específico (s)
  • Cómo utilizar múltiples res.srcDirs y anular algunos recursos con gradle
  • Sobreestablece la biblioteca buildConfigFields en la aplicación
  • Gradle, No se pudo expandir ZIP appcompat-v7: 19.0.1
  • Gradle Javadoc tarea sin advertencias
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.