de error con dependencias de bibliotecas adb en ubuntu de 64 bits

al intentar crear mi proyecto de prueba en una máquina Ubuntu 12.1:

adb install bin/opine_test-debug.apk adb: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory 

Así que voy a instalar lib64ncurses (estoy de hecho ejecutando un sistema operativo de 64 bits):

 sudo apt-get install lib64ncurses5 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: lib64ncurses5:i386 : Depends: lib64tinfo5:i386 (= 5.9-10ubuntu1) but it is not going to be installed Depends: libc6-amd64:i386 (>= 2.14) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

Y resulta que el paquete ofensivo es libc-amd64 :

 sudo apt-get install libc6-amd64 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libc6 : Conflicts: libc6-amd64:i386 but 2.15-0ubuntu20.1 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. 

Estoy oficialmente perplejo. ¿Qué clase de problemas es esto?

2 Solutions collect form web for “de error con dependencias de bibliotecas adb en ubuntu de 64 bits”

Tratar:

sudo apt-get install lib32ncurses5 lib32stdc++6

 *sudo apt-get install libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386 

para ejecutar el emulador necesitas ese paquete adicional:

 *sudo apt-get install libsdl1.2debian:i386 

luego instale ia32-libs:

 *apt-get install ia32-libs 
  • Eclipse ADB error
  • React-native Android Systrace HTML está en blanco en Ubuntu 14.04
  • No se puede conectar la versión 2.3.6 de Android en Ubuntu 12.04
  • Cordova - el módulo check_reqs falta para la plataforma. Saltando
  • El comando adb devices no muestra nada
  • Conectar el teléfono a la computadora hace que Eclipse se bloquee (peor después de actualizar a ICS)
  • El emulador de Android no instala la aplicación cuando se utiliza el comando 'emular android'
  • Cómo configurar la ruta ANDROID_HOME en ubuntu? Proporcione los pasos
  • No se pudo obtener la versión del anuncio ... Ningún archivo o directorio
  • ¿Por qué ADB Ubuntu no reconoce mi dispositivo?
  • Genymotion congela todo Ubuntu Desktop
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.