Crouton depende de las bibliotecas, pero no es una biblioteca en sí

Estoy usando Android Studio 0.6.1, con la biblioteca de Crouton y hoy después de gradle sync Tengo siguiente error:

Error:A problem occurred configuring root project 'project_name'. Module version de.keyboardsurfer.android.widget:crouton:1.8.4 depends on libraries but is not a library itself 

¿Eso está sucediendo?

2 Solutions collect form web for “Crouton depende de las bibliotecas, pero no es una biblioteca en sí”

Este problema se debe a la reciente actualización de com.android.support-v4.

Así que cambié

 compile 'com.android.support:support-v4:20.+' 

a

 compile 'com.android.support:support-v4:19.1.+' 

Y el cuscurrón funciona bien

Diferente solución es utilizar @aar:

 compile('de.keyboardsurfer.android.widget:crouton:1.8.4@aar') { exclude group: 'com.google.android', module: 'support-v4' } 

Mi solución de acuerdo con la respuesta @Revedko, utilizando @ aar y cambiar todos los soportes a la versión inferior a 21 -> 20. +

 dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.loopj.android:android-async-http:1.+' compile "com.bugsense.trace:bugsense:3.5" compile('de.keyboardsurfer.android.widget:crouton:1.8.4@aar') { exclude group: 'com.google.android', module: 'support-v4' } compile 'com.android.support:appcompat-v7:20.+' compile 'com.google.android.gms:play-services:5.0.77' } 
  • Cómo solucionar la entrada duplicada de entrada duplicada: javax / annotation / ParametersAreNullableByDefault.class
  • Error al configurar SDK: Error: Módulo 'app': plataforma 'Google Inc.: API de Google: 21' no encontrado
  • Cambiar las ubicaciones de salida de ndk-build
  • Error: org.gradle.api.internal.changedetection.state
  • ¿Qué es exactamente "configuración a la carta" en Gradle?
  • Gradle connectedAndroidTest devuelve "No se encontró ninguna prueba", sin embargo, el shell adb shell puede encontrar las pruebas
  • La ruta local de Android Studio no existe
  • La actualización de Android Studio 2.2 Gradle falla
  • Gradle muestra un error en la biblioteca de soporte: "La versión del módulo com.android.support:support-v13:19.0.1 depende de las bibliotecas pero no es una biblioteca en sí"
  • Ejecución de gradle's connectedAndroidTest en un dispositivo específico
  • Recurso ya definido gradle Android studio
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.