Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Cómo solucionar "Support-v13: 19.1.0 depende de las bibliotecas, pero no es una biblioteca en sí"?

Acabo de lanzar un proyecto en Android Studio 0.8.1 por primera vez desde la actualización de 0.6.2.

El error lanzado es "Error: la versión del módulo com.android.support:support-v13:19.1.0 depende de las bibliotecas pero no es una biblioteca en sí".

¿Alguien tiene una idea de por qué esto es? He instalado algunas de las nuevas cosas API20 para jugar con Android L, pero las buildTools para este proyecto todavía están configuradas para 19.1.0.

Aquí está la sección de dependencias de mi build.gradle:

dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:19.1.+' compile 'com.android.support:support-v13:19.1.+' compile 'com.jakewharton:butterknife:5.1.0' compile 'de.greenrobot:eventbus:2.2.1' compile 'com.google.code.gson:gson:2.2.4' compile 'com.mcxiaoke.viewpagerindicator:library:2.4.1' compile 'uk.co.chrisjenx:calligraphy:0.7.+' compile 'com.crashlytics.android:crashlytics:1.+' compile 'com.google.android.gms:play-services:4.4.+' } 

Los ajustes de SDK / Buildtools son los siguientes:

 compileSdkVersion 19 buildToolsVersion "19.1.0" 

¿Puede alguien explicar esto o señalarme hacia una solución? Estoy perplejo.

One Solution collect form web for “Cómo solucionar "Support-v13: 19.1.0 depende de las bibliotecas, pero no es una biblioteca en sí"?”

Parece que el support-v13:19.1.0 podría tener metadatos incorrectos. Intente cambiar a

compile 'com.android.support:support-v13:20.0.0' y ver si su problema persiste?

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.