Cómo solucionar el problema de incompatibilidad de Gradle al importar un proyecto de muestra de Android

Android Studio (0.5.3) me está volviendo loco.

Nunca he tenido problemas serios con Eclipse y ADT. Android Studio es otra historia: no he podido conseguir un solo proyecto para construir correctamente con él.

Por lo tanto, estoy tratando de importar un proyecto de muestra de Android (que supongo que tiene la configuración correcta Gradle y debe estar listo para ser importado):

C:\pathToMyAndroidSDK\sdk\samples\android-19\content\StorageProvider 

El primer error que recibo es el siguiente:

 Failed to refresh Gradle project 'StorageProvider' The project is using an unsupported version of Gradle. Please use version 1.10. Please point to a supported Gradle version in the project's Gradle settings or in the project's Gradle wrapper (if applicable.) Fix Gradle wrapper and re-import project Gradle settings 

Aceptar, por lo que descarga Gradle 1.10 y cambiar la configuración de Gradle del proyecto, para que utilice esta distribución local de Gradle en lugar del contenedor gradle predeterminado (que parece estar incluido en el proyecto de ejemplo).

Tengo un error diferente esta vez:

 Failed to refresh Gradle project 'StorageProvider' The project is using an unsupported version of the Android Gradle plug-in (0.8.3). Version 0.9.0 introduced incompatible changes in the build language. Please read the migration guide to learn how to update your project. 

No sé Gradle lo suficiente como para migrar la configuración yo mismo, y realmente no quiero hacerlo.

¿Cómo puedo simplemente usar el gradle wrapper sin gettting convocado para usar Gradle 1.10 (que no es compatible con el proyecto)? Cualquier otra solución también es bienvenida.

Nota: He intentado con otros proyectos de ejemplo en la carpeta android-19, sólo para obtener los mismos errores.


EDITAR:

He tenido más suerte intentando construir bajo Linux con la línea de comandos ( gradlew build ).

La compilación tuvo éxito, independientemente de lo que establezca en build.gradle :

 classpath 'com.android.tools.build:gradle:0.9.+' 

o

 classpath 'com.android.tools.build:gradle:0.8.+' #(the original configuration of the sample project) 

Así que mi problema parece ser causado por los errores en Android Studio.

3 Solutions collect form web for “Cómo solucionar el problema de incompatibilidad de Gradle al importar un proyecto de muestra de Android”

Sin saber Gradle, es bastante difícil de resolver este problema.

Al mismo tiempo Android Studio es una versión alfa, por lo que puede cambiar rápidamente, y cada versión puede introducir cambios incompatibles

Aquí el primer documento para leer sobre un proyecto con Android Studio: https://developer.android.com/sdk/installing/studio-build.html

Estás utilizando AS 0.5.3 por lo que tienes que usar gradle 1.10 / 1.11 y el plugin gradle 0.9.x

Esto significa que en tu script build.gradle tienes que usar:

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.+' } } 

Puede estar en su archivo tiene 0.8.3.

También tienes que usar gradle 1.10 / 1.11. Debe tener una carpeta project_folder / gradle / wrapper donde hay un archivo gradle-wrapper.properties.

Aquí tienes que cambiar la clave distributionUrl para usar una de estas versiones:

DistributionUrl = http: //services.gradle.org/distributions/gradle-1.10-all.zip

Android Studio – Gradle – Gradle plugin tiene alguna relación:

Android Studio Gradle problema de actualización a la versión 0.5.0 – Gradle de la migración de 0,8 a 0,9 – También Android Studio actualización a 0,8.1

Puede ser que su script gradle pueda tener otros problemas después de estos cambios.

Lo único que funcionó para mí, fue cambiar el lugar en el que Android Studio busca los archivos gradle.

Utilizando gradle-wrapper.properties (generado automáticamente) desde gradle 2.10 y superior es mucho más fácil

No olvide el control de versiones de gradle-wrapper.properties como se sugiere aquí: https://docs.gradle.org/current/userguide/gradle_wrapper.html

Selección para resolver el problema de las versiones gradle

En la configuración de la estructura del proyecto como esta en la imagen:

Introduzca aquí la descripción de la imagen

  • Wear App y con tipo de compilación personalizado con applicationIdSuffix
  • No se puede encontrar el botón "Sincronizar proyecto con archivos Gradle" en IntelliJ IDEA
  • Android GCM con sabores de producto
  • Archivos duplicados copiados en APK META-INF / maven / com.squareup / otto / pom.xml
  • Gradle versión 1.8 es necesario. La versión actual es 1.9-rc-3 - Android Studio
  • ¿Qué es Gradle en Android Studio?
  • Especificar firma de configuración para Gradle y Cordova 5
  • Cambiar las ubicaciones de salida de ndk-build
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.