¿Cómo configuro la versión Gradle en Android Studio 1.3?

He actualizado al estudio de Android a la versión 1.3. En mi proyecto necesito usar gradle versión 2.2.1 y androide gradle plugin versión 1.0.0. ¿Cómo puedo configurar android studio para usar gradle versión 2.2.1 automáticamente?

He fijado el gradle envoltura-properities a 2.2.1 y en la estructura del proyecto también demuestra que está utilizando gradle versión 2.2.1

Gradle-wrapper.properties

#Wed Apr 10 15:27:10 PDT 2013 distributionBase=GRADLE_USER_HOME distributionPath=wrapper/dists zipStoreBase=GRADLE_USER_HOME zipStorePath=wrapper/dists distributionUrl=https\://services.gradle.org/distributions/gradle2.2.1-all.zip 

Salida:

Error: Gradle 2.4 requiere Android Gradle plugin 1.2.0 (o más reciente), pero el proyecto está utilizando la versión 1.0.0. Utilice Android Gradle plugin 1.2.0 o corrija la versión de plugin y sincronice el proyecto

Quiero usar Gradle 2.2.1 pero sigue saltando a 2.4

3 Solutions collect form web for “¿Cómo configuro la versión Gradle en Android Studio 1.3?”

Estaba recibiendo el mismo error en Android Studio y resulta que Android Studio estaba apuntando a su propia versión de gradle en lugar de mi envoltorio gradle proyecto.

Para Windows Android Studio, vaya a File> Settings> "Build, Execution, Deployment"> "Build Tools"> Gradle y cámbielo a "Use gradle wrapper por defecto (recomendado)".

Esto lo arregló para mí sin tener que cambiar las dependencias. Esperemos que esto es todo lo que necesita.

En build.gradle de su proyecto (no el módulo de su aplicación) asegúrese de que su uso de android gradle construir herramientas de 1.2.0 o superior. Por lo tanto, en su archivo, la sección de dependencia debería verse así:

 dependencies { classpath 'com.android.tools.build:gradle:1.3.+' } 

Si siempre desea las herramientas de compilación de gradles más recientes, cámbielo a:

 dependencies { classpath 'com.android.tools.build:gradle:+' } 

Desde OP:

Este dosnt resolver mi problema. Necesito a la versión del plugin del usuario 'com.android.tools.build:gradle:1.0.0' en mi proyecto, así que lo he fijado a esto en mi archivo del proyecto build.gradle. El problema que tengo es que esto funcionó con el uso de gradle 2.2.1, pero desde android Studio 1.3 está utilizando gradle 2.4 no está funcionando. Así que necesito de alguna manera obtener estudio de Android para usar gradle versión 2.2.1 para que pueda utilizar gradle plugin 1.0.0.

Se recomienda utilizar los últimos Gradle thats por qué Android Studio advierte para actualizar a la versión más reciente.

¿Por qué desea volver a la versión anterior?

Nota: Si piensas que la versión más reciente creará cualquier complicación en tu código estable, estarán seguros de que no causará ningún daño a tu código. Y no puede obtener ningún beneficio adicional de la versión anterior. La versión más reciente significa más eficiente y libre de errores.

  • ¿Cómo puedo solucionar un error de `android.app.Application no se puede enviar a`
  • La adición de un día a un calendario en Android falla el 31
  • ¿Cómo encontrar una palabra en la lista de palabras grande (vocabulario) con el consumo de memoria de descenso y el tiempo de búsqueda?
  • Error "No se encontró ningún identificador de recurso para el atributo 'rectLayout'"
  • Cómo programar una ejecución de código en android o: ¿qué son exactamente los hilos de daemon en android?
  • Manejo de eventos de aplicaciones de Android
  • Android - Iniciar el servicio en el arranque
  • Ya administra un GoogleApiClient con id 0 En FRAGMENT
  • Incapaz de referir proyecto de biblioteca android en adt actualizado
  • Cómo utilizar ScriptIntrinsic3DLUT con un archivo .cube?
  • System.lineSeparator () no existe en android
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.