Cómo cambiar la minSdkVersion de un proyecto?

He estado construyendo un proyecto y probándolo en el emulador de Android.

Me di cuenta de que establecer el minSdkVersion a 10. Ahora, tengo un teléfono para probar el programa, pero su versión sdk es 7.

Intenté entrar en el archivo de manifiesto, y cambiar la versión de sdk a 7, pero cada vez que ejecuto el programa, se bloquea.

¿Cómo puedo reconstruir o cambiar la versión de sdk a un número inferior (de 10 a 7), para que pueda asegurarme de que mi aplicación pueda ejecutar en teléfonos antiguos?

Cree un nuevo AVD con el Administrador de AVD y establezca el objetivo en el nivel de API 7. Intente ejecutar su aplicación con ese AVD. Además, asegúrese de que su min sdk en su archivo de manifiesto es al menos establecida en 7.

Establezca la versión min SDK dentro del archivo AndroidManifest.xml de su proyecto:

 <uses-sdk android:minSdkVersion="4"/> 

¿Qué causa exactamente el accidente? Hierro todos los accidentes / bugs en versión mínima y luego prueba en versiones superiores.

En su archivo app/build.gradle , puede establecer la minSdkVersion dentro de defaultConfig .

 android { compileSdkVersion 23 buildToolsVersion "23.0.3" defaultConfig { applicationId "com.name.app" minSdkVersion 19 // This over here targetSdkVersion 23 versionCode 1 versionName "1.0" } 

Abra el archivo app/build.gradle y compruebe el campo de propiedad compileSdkVersion en la sección android . Cambiar a lo que usted prefiere.

Si ha importado bibliotecas externas en su aplicación (por ejemplo: facebook), asegúrese de revisar facebook/build.gradle también.

Establezca la versión min SDK en el archivo AndroidManifest.xml de su proyecto y, en la barra de herramientas, busque el icono "Sincronizar proyectos con archivos Gradle". Esto funciona para mi.

También busque el archivo build.gradle de su proyecto y actualice la versión min sdk.

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.