Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Tag: Gradle

Error de dependencia al utilizar una biblioteca aar

Tengo un módulo con un archivo .aar en la carpeta libs. He utilizado la solución publicada aquí [1]: http://kevinpelgrims.com/blog/2014/05/18/reference-a-local-aar-in-your-android-project/ para agregar el archivo .aar como dependencia Y fue capaz de compilar el módulo correctamente. Ahora quiero usar este módulo como una dependencia al módulo principal en mi proyecto y compilar. Sin embargo, cuando intento compilar, […]

Estudio Android – lanzamiento de APK para el sabor

Soy nuevo en Android Studio y ejecutar una compilación de depuración en un dispositivo está funcionando bien, sin embargo, para probar en la compra de aplicaciones (y, obviamente, para liberar) Necesito una versión de construcción firmado con la clave normal. Puedo hacer un APK usando Build -> Generate firmado APK, sin embargo el nombre del […]

Android studio 2.3 refrescante gradle proyecto de tomar para siempre

He actualizado mi estudio de Android a la nueva versión 2.3 y se le pidió que convertir mi proyecto para que coincida con los nuevos formatos que hice. Me pidieron que actualizar la versión gradle también y lo hice. Ahora una eternidad más adelante todavía refresca mi gradle del proyecto. He reiniciado varias veces y […]

'FlavorDimension' será eliminado por Android Gradle Plugin 2.0, ha sido reemplazado por 'dimension'

A partir de com.android.tools.build:gradle:1.3.0 obtendrá 'flavorDimension' will be removed by Android Gradle Plugin 2.0, it has been replaced by 'dimension'. Este es mi archivo de compilación: Construir un gradiente android { flavorDimensions "store", "api" productFlavors { googleplay { flavorDimension "store" } amazon { flavorDimension "store" } pre21 { flavorDimension "api" } post21 { flavorDimension "api" […]

Gradle kotlin Método no soportado Dependencies.getAtoms ()

Acabo de iniciar un nuevo proyecto de Android con Studio 3.0 Canary 3 utilizando kotlin y sólo tratando de conseguir que se haga una sincronización de proyecto gradle. Actualmente falla con Error:Unsupported method: Dependencies.getAtoms(). The version of Gradle you connect to does not support that method. To resolve the problem you can change/upgrade the target […]

¿Cómo utilizar Gradle para generar JavaDoc en Android Studio?

No puedo encontrar ninguna documentación sobre cómo configurar mi archivo Gradle para crear el JavaDoc para mi proyecto. Ya he probado algunos fragmentos de SO y artículos de blog, pero ninguno de ellos parece funcionar o no proporcionan contexto. Este es mi archivo Gradle. ¿Qué debo hacer para agregar una tarea para generar JavaDoc? import […]

Tarea de gradación de Android Google Appengine

Estoy tratando de escribir una tarea de gradle para mi aplicación de Android que inicia el servidor de desarrollador appengine de google, ejecuta una prueba y, a continuación, cierra el servidor. Lo que he probado hasta ahora se parece a esto: task runAppEngine (dependsOn: ":backend:appengineRun") <<{ //run test //stop development server } La tarea appengineRun […]

Error: El proyecto utiliza una versión no compatible del complemento Android Gradle (0.12.2)

Después de la actualización de Android Studio No puedo ejecutar mi aplicación – Tengo esta excepción: Error:The project is using an unsupported version of the Android Gradle plug-in (0.12.2). The recommended version is 1.0.0-rc4. Esta es mi buld.gradle dependencias dependencies { classpath 'com.android.tools.build:gradle:0.12.+' classpath 'com.crashlytics.tools.gradle:crashlytics-gradle:1.+' } UPDATE He cambiado en build.gradle y ahora tengo este […]

Gradle Android: Cómo mostrar los resultados de las pruebas sin usar –info

Estoy realizando pruebas android usando el complemento Android de Gradle y quiero ver los resultados de las pruebas individuales. De respuestas a esta pregunta Gradle: ¿Cómo mostrar los resultados de la prueba en la consola en tiempo real? Parece que puedo usar –info (que imprime un montón de otros basura verbosa que no me importa) […]

Estudio de Android importando en edición de gradle

Soy nuevo en Android Studio y estaba tratando de importar mi proyecto eclipse . Estoy tratando de resolver este problema durante bastante tiempo pero ahora no puedo. Tengo un proyecto mainactivity que utiliza mmany otras librerías staggeredgridview, devsmart, google maps y appcompactv7 . Estoy recibiendo 2 errores siguientes. Nota: el proyecto mainactivity es el que […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.