Tag: Gradle

Quitar la biblioteca externa de clases obfuscated.jar (en Android Studio / Gradle)

He creado una biblioteca de Android (con Android Studio), que importa un archivo .jar externo (que contiene sólo interfaces) para poder construir correctamente. Sin embargo, el archivo final de la biblioteca no debe incluir este archivo, ya que el proyecto principal de la aplicación incluirá un archivo .jar que ya contiene estas clases de interfaz […]

Distribución de Crashlytics con múltiples sabores

Tengo varios flavors y tratar de distribuirlos por separado usando Beta Distribution : productFlavors { appOne{ applicationId 'com.example.appOne' manifestPlaceholders = [ appName: "AppOne", fabricApiKey: "AppOne APi Key"] } appTwo{ applicationId 'com.example.appTwo' manifestPlaceholders = [ appName: "AppTwo", fabricApiKey: "AppTwo APi Key"] } AndroidManifest: <meta-data android:name="io.fabric.ApiKey" android:value="${fabricApiKey}" /> He creado dos organizaciones diferentes, las aplicaciones construidas basadas […]

Error: Error de ejecución para la tarea ': app: mergeDebugResources'. > Java.lang.ArrayIndexOutOfBoundsException (sin mensaje de error)

¿Alguien de ustedes sabe esta excepción en la compilación de Gradle? Error:Execution failed for task ':app:mergeDebugResources'. > java.lang.ArrayIndexOutOfBoundsException (no error message) Mi proyecto funcionó bien, hasta que implementé un reproductor de vídeo en una nueva actividad que analiza un archivo MP4 desde la tarjeta SD. Entonces recibí esta excepción. Después de que actualizé Android Studio, […]

Android Gradle produce una excepción TransformException: java.util.zip.ZipException: error en abrir archivo zip durante transformClassesWithDexForRelease

Tengo un proyecto en android studio para una aplicación de Android. El proyecto cuenta con 6 módulos (3 bibliotecas internas, un módulo de aplicación android, un módulo portátil y un módulo para compartir código entre aplicaciones y portátiles), todo funcionaba bien hasta que decidimos cambiar el sdk android mínimo para la aplicación. Era originalmente compatible […]

Android Studio: Resolución de clases duplicadas

Cuando intento run mi aplicación Android en un dispositivo Android, la consola gradle informa del siguiente error: Error:Execution failed for task ':app:transformClassesWithJarMergingForDebug'. > com.android.build.api.transform.TransformException: java.util.zip.ZipException: duplicate entry: com/loopj/android/http/AsyncHttpClient$1.class Cuando busco la clase "AsyncHttpClient", veo que realmente se encuentra en dos ubicaciones separadas: /Users/Afflatus/.gradle/caches/modules-2/files-2.1/com.loopj.android/android-async-http/1.4.9/5d171c3cd5343e5997f974561abed21442273fd1/android-async-http-1.4.9-sources.jar!/com/loopj/android/http/AsyncHttpClient.java /Users/Afflatus/.ideaLibSources/android-async-http-1.4.9-sources.jar!/com/loopj/android/http/AsyncHttpClient.java El primer camino parece sugerir que es un archivo "caché" … […]

Problema de compilación de Gradle: actualización de Quickblox y httpclient en el último SDK23 de Android

Estoy tratando de actualizar la aplicación android (que utiliza Quickblox y httpclient para la comunicación con el servidor) hasta el último SDK 23. Tengo algunos problemas. Sé que httpclient no es compatible con SDK23. Puede comprobar el error a continuación: Process: com.a.test, PID: 26761 java.lang.NoClassDefFoundError: Failed resolution of: Lde/measite/minidns/Client; at org.jivesoftware.smack.util.dns.minidns.MiniDnsResolver.<init>(MiniDnsResolver.java:50) at org.jivesoftware.smack.util.dns.minidns.MiniDnsResolver.<clinit>(MiniDnsResolver.java:45) at java.lang.Class.classForName(Native […]

Añadir dependencia gradle para dar soporte a android.util.ArrayMap

Tengo un proyecto de ejemplo que tiene una dependencia gradle para apoyar la biblioteca compile 'com.android.support:support-v4:23.1.1' Cuando ejecuto el programa esto a veces ocurre esta excepción: Could not find class 'android.util.ArrayMap', referenced from method com.android.tools.fd.runtime.MonkeyPatcher.monkeyPatchExistingResources Busqué y descubrí que debería añadir esta dependencia a gradle: compile "com.android.support:support-core-utils:23.3.0" O compilar "com.android.support:support-core-utils:24.2.0" Así que agregué dependencia a […]

Cómo utilizar maven en el estudio android

Quiero utilizar la biblioteca bottomBar en mi proyecto. Cuando agrego el comando gradle adecuado en el archivo build.gradle y la sync , obtengo este error: Failed to resolve: com.roughike:bottom-bar:2.0 He buscado mucho por la razón. Una solución es usar jcenter (), pero esto no es accesible en mi país y la sincronización dura hasta 1 […]

Android gradle ndk jni construir con biblioteca externa y depuración nativa (ARToolkit)

Estoy intentando tener el estudio del androide para ser mi IDE principal del desarrollo para el código de Java y c / c ++. Quiero ser capaz de depurar código nativo. En este caso estoy tratando de utilizar ARToolkit5 como una biblioteca. Debido a algunos ejemplos en el ARToolkit5 estoy teniendo este archivo de construcción. […]

Implementar la aplicación de Android. Falta la tarea 'installReleaseDebug' para gradle

Trato de desplegar la versión de liberación de mi aplicación. En resumen, describo lo que he hecho: He generado el archivo del almacén de claves, establezca las propiedades en el archivo build.gradle para la configuración de la versión según esta documentación ( https://facebook.github.io/react-native/docs/signed-apk-android.html ). Tengo un mensaje de error después de comando react-native run-android –variant […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.