Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Tag: Gradle

¿Instaló la última versión de Android Studio, se produjo la excepción cuando construí el proyecto?

Un proyecto Android, fue bueno con la versión anterior de Android Studio. Pero después de actualizar la versión IDE, se producirá una excepción cuando construya el proyecto con gradle. Aquí está el problema: Error: Error de ejecución para la tarea ': jellyrefresh: compileReleaseJava'. Al ejecutar gradle con java 5, 6 ó 7, debe establecer la […]

Importación de la biblioteca arrastrar-ordenar-lista en Android Studio gradle project

Estoy intentando importar la biblioteca android de drag-sort-listview en mi aplicación en Android Studio. No tuve problemas para usarlo con Eclipse antes. Repositorio Git para la biblioteca: https://github.com/bauerca/drag-sort-listview

Gradle: applicationVariants.all salta una variante

Estoy usando Gradle para compilar mi proyecto de Android: buildTypes { release { signingConfig signingConfigs.release applicationVariants.all { variant -> def file = variant.outputFile def fileName = file.name fileName = fileName.replace(".apk", "-renamed".apk") variant.outputFile = new File(file.parent, fileName) } } } No todos los archivos de salida se cambian de nombre, siempre omite 1 archivo. ¿Por qué? […]

Gradle build: La ejecución falló para la tarea ': app: lint'

Estoy usando Android Studio 2.0 y estaba tratando de ejecutar mi programa cuando sucedió algo extraño. Corrí el comando de construcción del gradle y recibí este error: FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':app:lint'. > Lint found errors in the project; aborting build. Fix the issues identified […]

Android Gradle compilar commons-io crea duplicado en el árbol de la biblioteca

Estoy tratando de construir y mantener una antigua aplicación para el trabajo, pero no puedo pasar la fase de construcción. En mi archivo app/build.gradle tengo dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.apache.commons:commons-io:1.3.2' //some more libraries compiled as well } Pero obtiene el siguiente error al intentar ejecutar: Error: Error de ejecución para la […]

Minify la aplicación para Android, pero no la ofusque

Cuando no minify mi aplicación alcanzo el conteo máximo del método y la construcción del archivo dex falla. Esto se puede evitar al habilitar build.gradle en build.gradle . La desventaja, sin embargo, es que ahora el código se ofusca. Esto es correcto para la generación de versión pero es problemático para una compilación de depuración. […]

Gradle muestra un error en la biblioteca de soporte: "La versión del módulo com.android.support:support-v13:19.0.1 depende de las bibliotecas pero no es una biblioteca en sí"

Esto es lo que mi build.gradle dice: apply plugin: 'android' apply plugin: 'crashlytics' apply from : '../gradle/checkstyle.gradle' apply from : '../gradle/pmd.gradle' compileSdkVersion 19 buildToolsVersion "19.0.3" defaultConfig { minSdkVersion 17 targetSdkVersion 19 } Pero veo este error de compilación: Gradle 'mobi-client-connect-android-mobile' project refresh failed: Module version com.android.support:support-v13:19.0.1 depends on libraries but is not a library itself

Error de sincronización de Gradle: No se puede cargar la biblioteca windows-amd64 \ native-platform.dll

Actualizado desde Android Studio 1.4 a 2.0, y tenía el IDE cambiar mi dependencia gradle a 2.0 de 1.x en el build.gradle: dependencies { classpath 'com.android.tools.build:gradle:2.0.0' } Actualización de la versión gradle del proyecto a 2.10. Cuando intenté sincronizar un proyecto con los archivos gradle, o actualizar el proyecto, ahora obtengo el siguiente error: Gradle […]

Jvm opciones en android cuando se ejecuta gradlew test

Tengo un proyecto que utiliza Robolectric para el propósito de prueba de unidad. Este proyecto utiliza Robolectric 3.0 y necesita agregar opciones -noverify y -noverify en las opciones de Virtual Machine. En Android Studio, creé la nueva configuración de JUnit en Run > Edit Configurations… y luego establecer las VM Options en -ea -noverify . […]

Error al importar un proyecto de Eclipse en Android Studio

Estoy intentando importar un proyecto hecho en Eclipse a Android Studio. Durante la importación, estoy recibiendo el siguiente error: "There are unrecoverable errors which must be corrected first" Library reference ../../../../workspace/android-support-v7-appcompat could not be found He intentado copiar appcompat carpeta en el directorio raíz del proyecto, sigue siendo el mismo error. ¿Cómo puedo resolverlo? Consulte […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.