Tag: build.gradle

Error: Error de ejecución para la tarea ': app: processDebugGoogleServices

Tengo un error en Android Studio. Nueva aplicación de actividad en blanco, agrego "build.gradle (project)" dependencies { classpath 'com.android.tools.build:gradle:2.0.0-alpha9' classpath 'com.google.gms: google-services: 2.0.0-alpha9' } Y en "build.gradle (app)" dependencies { compile FileTree (dir: 'libs', include: ['* .jar']) compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' // Dependency for Google Sign-In compile 'com.google.android.gms: play-auth-services: 8.4.0' } apply plugin: 'com.google.gms.google-services' Compilar, […]

Gradle-experimental: 0.1.0 buildConfigField

Alguien sabe cómo definir buildConfigField en el complemento gradle experimental? android.productFlavors { create("demo") { applicationId = 'com.anthonymandra.rawdroid' buildConfigField "String", FIELD_META, PROVIDER_META } da: Error: Intento de leer una vista de sólo escritura del modelo de tipo 'java.lang.Object' dada a la regla 'model.android.productFlavors'

¿Cómo usar com.android.databinding en el módulo (estudio de Android)?

Quiero crear una biblioteca usando com.android.databinding: dataBinder . Build.gradle para el proyecto: buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.5.0' classpath 'com.android.databinding:dataBinder:1.0-rc4' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() maven { url "https://jitpack.io" } //gradlew […]

Android Studio 1.0.0 – Error al encontrar butterknife: 6.0.0

Estoy usando Android Studio 1.0.0. Estoy tratando de añadir dependencias de butterknife. dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:21.0.3' compile 'com.jakewharton:butterknife:6.0.0' compile 'com.google.android.gms:play-services:6.1.11' compile 'com.android.support:recyclerview-v7:21.0.2' } Pero estoy recibiendo el siguiente error Gradle: Error: No se pudo encontrar: com.jakewharton: butterknife: 6.0.0

¿Es posible establecer el código de la versión de Android y el nombre a través de una tarea de Gradle?

Estoy tratando de automatizar el proceso de construcción en CI con el que estoy trabajando. Puedo llamar a un curl y asignarle algunas variables como código de versión y nombres. Entonces CI (en mi caso, Bitrise CI) lo captura e inicia la generación de Release. Sin embargo, antes de que quiero establecer el código de […]

Obtenga el tipo de generación gradle en el sabor del producto

Necesito crear diferentes nombres de aplicación dependiendo del sabor del producto utilizado. Si bien esto fue fácil simplemente estableciendo un recurso de cadena, ya no puedo hacer eso porque cuando la aplicación se carga en hockeyapp el nombre de la aplicación se establece como '@ string / app_name' en lugar del valor de app_name. He […]

Android versión sdk en gradle y manifiesto

Empecé a usar Android Studio hace unas semanas y hay una pregunta que tengo, en el archivo build.gradle podemos establecer la minSdkVersion como podemos en el manifiesto, pero ¿uno anula al otro? Si ponemos diferentes valores en gradle y en el manifiesto cuál es la consecuencia?

El proyecto Biblioteca de Android no puede importar la clase R de otro proyecto de biblioteca al utilizar gradle para compilar en la línea de comandos

Tengo esta estructura para mi proyecto androide: ProjectDir settings.gradle MyApp(depends on LibraryA and LibraryB) –>build.gradle –>All the other android code LibraryA (depends on LibraryB) –>build.gradle –>All the other android code LibraryB (Has lots of resources that are used in LibraryA and MyApp) –>build.gradle –>All the other android code Puedo compilar la aplicación android muy bien […]

La ejecución falló para la tarea 'app: prepareDebugAndroidTestDependencies'

Estoy tratando de crear pruebas de interfaz de usuario para mi aplicación de Android en Android Studio. El problema es que no puedo ejecutarlos. Recibo el mensaje: La ejecución falló para la tarea 'app: prepareDebugAndroidTestDependencies' que no pude encontrar de qué se trata. Cuando ejecuto mi aplicación, se inicia perfectamente, pero cuando intento ejecutar pruebas […]

La tarea Gradle no se ejecuta en Android Studio

He intentado que una tarea de gradle se ejecute para un módulo lib 'lib1' en un proyecto de Android Studio. Debe ejecutarse con el comando 'gradlew assembleDebug' o 'gradlew assemble' pero nunca se ejecuta. task copy(type: Copy, dependsOn: ':lib1:assembleDebug') << { println "copying" } He intentado una tarea más simple sin dependencia y nunca parece […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.