Tag: build.gradle

No puedo compilar mi proyecto android

Cuando intento compilar mi proyecto androide iam conseguir el siguiente error. Error:A problem occurred configuring project ':app'. Could not resolve all dependencies for configuration ':app:_debugCompile'. Could not find com.android.support:appcompat-v7:21.0.1. Searched in the following locations: https://jcenter.bintray.com/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.jar file:/home/baman/Android/Sdk/extras/android/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.pom file:/home/baman/Android/Sdk/extras/android/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.jar file:/home/baman/Android/Sdk/extras/google/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.pom file:/home/baman/Android/Sdk/extras/google/m2repository/com/android/support/appcompat-v7/21.0.1/appcompat-v7-21.0.1.jar Required by: SriLankaTemples:app:unspecified Could not find com.android.support:recyclerview-v7:21.0.1. Searched in the following locations: https://jcenter.bintray.com/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.pom https://jcenter.bintray.com/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.jar file:/home/baman/Android/Sdk/extras/android/m2repository/com/android/support/recyclerview-v7/21.0.1/recyclerview-v7-21.0.1.pom […]

No se puede importar el proyecto al estudio de Android

Estoy tratando de usar esta biblioteca he añadido compile 'net.rdrei.android.dirchooser:library:2.0@aar' A dependencias. Mi archivo de compilación de nivel superior // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.8.+' } } allprojects { repositories { mavenCentral() } } Y me da […]

Gradle acabado con valor de salida distinto de cero 3

Mi proyecto contiene 3 bibliotecas: calendar_cmcc , Wheel_library y yellowPage_lib . Puedo construir el proyecto perfectamente, pero gradle lanza un error cuando lo corro. Aquí está el error: Error:Execution failed for task ':app:dexDebug'. Com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command' /home/jim/tools/jdk1.8.0_45/bin/java '' terminado con valor de salida distinto de cero 3 Lista de archivos gradle: App build.gradle: apply […]

ViewPagerIndicator: Error: Artefacto 'com.viewpagerindicator: library: 2.4.1: library.aar' no encontrado

Cuando sincronizo el gradle Tengo este error: Error: Artefacto 'com.viewpagerindicator: library: 2.4.1: library.aar' no encontrado. Mi gradle es: apply plugin: 'com.android.application' repositories { maven { url "http://dl.bintray.com/populov/maven" } mavenCentral() } android { compileSdkVersion 20 buildToolsVersion "20.0.0" defaultConfig { minSdkVersion 14 targetSdkVersion 19 } packagingOptions { exclude 'META-INF/LICENSE' exclude 'META-INF/DEPENDENCIES' exclude 'META-INF/NOTICE' } } dependencies { […]

Error: Error de ejecución para la tarea ': app: mergeDebugResources'. > Se ha producido un error en el procesamiento de archivos, vea los registros para obtener detalles.

Actualmente estoy usando Android Studio 2.1 cuando ejecuto mi aplicación me muestra algún error en Gradle de mensajes de construcción diciendo lo siguiente Information:Gradle tasks [:app:clean, :app:generateDebugSources, :app:prepareDebugUnitTestDependencies, :app:mockableAndroidJar, :app:generateDebugAndroidTestSources, :app:assembleDebug] :app:clean :app:preBuild UP-TO-DATE :app:preDebugBuild UP-TO-DATE :app:checkDebugManifest :app:preReleaseBuild UP-TO-DATE :app:prepareComAndroidSupportAppcompatV72221Library :app:prepareComAndroidSupportDesign2221Library :app:prepareComAndroidSupportSupportV42221Library :app:prepareDebugDependencies :app:compileDebugAidl :app:compileDebugRenderscript :app:generateDebugBuildConfig :app:mergeDebugShaders :app:compileDebugShaders :app:generateDebugAssets :app:mergeDebugAssets :app:generateDebugResValues UP-TO-DATE :app:generateDebugResources :app:mergeDebugResources AAPT […]

Depósitos personalizados de Gradle y resolución de dependencias

Un proyecto que estoy desarrollando requiere bibliotecas scribe-java y crashlytics . Ambas bibliotecas están disponibles en repositorios personalizados. build.gradle parece a: buildscript { repositories { maven { url 'http://download.crashlytics.com/maven' } } dependencies { classpath 'com.crashlytics.tools.gradle:crashlytics-gradle:1.+' } } apply plugin: 'android' apply plugin: 'crashlytics' repositories { // is required by Crashlytics library maven { url 'http://download.crashlytics.com/maven' […]

Crear prueba Android apk utilizando el sistema de compilación gradle

Estoy migrando mi proyecto de Android a gradle construir el sistema y no puedo importar mi proyecto de Android de mi proyecto de integración de Android de la prueba. Estoy usando la configuración de varios proyectos con varias librerías android y funciona muy bien, pero tengo un problema al configurar mi proyecto de prueba con […]

Cómo agregar dependencia de prueba con android gradle plugin experimental 0.1.0

He seguido esta guía para construir un proyecto híbrido ndk en Android Studio 1.3.0 RC1 con gradle-experimental: 0.1.0 . Todo está bien, pero si intento agregar la dependencia de biblioteca de prueba, he encontrado el método androidTestCompile no es compatible más. Me gusta esto: Y testCompile también causa el mismo error. El guía oficial no […]

Los archivos múltiples de dex definen Landroid / support / v4 / en android studio

Puedo integrate (add & work) with many libraries . Pero en cuanto a la biblioteca de ActionBarSherlock , tengo tantos problemas con ella. El primer problema es el problema popular Multiple dex files define , Sé que el duplicated android-support-v4.jar causa, pero no puedo resolver este problema ahora: Error:Execution failed for task ':fitness:dexDebug'. Error Code: […]

¿Cómo forzar a Android Studio a construir con la biblioteca actualizada NDK, sin tener que limpiar y construir todo el proyecto?

¿Cómo puedo obligar a Android Studio a crear mi aplicación usando el archivo actualizado de biblioteca compartida NDK (.so), sin tener que limpiar todo el proyecto primero? Debe haber algún mecanismo por el cual Android Studio pueda detectar que la biblioteca compartida se ha actualizado y utilizar la más reciente. Si hago un Build-> Clean […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.