Tag: build.gradle

Error: Error de ejecución para la tarea ': app: packageDebug'

Estoy usando Android Studio 2.1.1 y muchas veces en el edificio de Gradle me da debajo del mensaje. ¿Puede alguien ayudarme con él! Creo que hay algún problema de memoria en Android Studio. Error:Execution failed for task ':app:packageDebug'. > value (119282) > 0x0000ffff Y después de reiniciar, funciona perfecto. Es extraño porque en la versión […]

Eliminar archivo / jar / class de una ruta gradle en android studio

Tengo multidex activado y estoy usando org.apache.http.legacy.jar y agregó jumblr gradle camino en mi archivo gradle.Yo estoy recibiendo la excepción Error:Execution failed for task :app:packageAllDebugClassesForMultiDex'. > java.util.zip.ZipException: duplicate entry: org/apache/commons/codec/binary/Base64.class Creo que esto es porque jumblr también está usando la biblioteca http legacy así que creo que necesito para eliminar explícitamente la http legacy library […]

Añadir Android Library a un proyecto existente en Android Studio 0.3.6

Estoy intentando agregar una biblioteca, https://github.com/edmodo/cropper , a mi proyecto de Android. Estoy siguiendo los métodos descritos aquí: ¿Cómo agrego un proyecto de biblioteca a Android Studio? Pero Android Studio ha cambiado desde entonces y ya no puedo "importar un módulo". Sólo puedo añadir uno nuevo. Estos son los pasos que he intentado: Copie la […]

Android Studio – Construye un proyecto Android con una biblioteca de Android que depende de otra Android Library

Necesito construir con Gradle un proyecto de Android que depende de un proyecto de la Biblioteca de Android A, que depende de otro proyecto de la Biblioteca de Android B. Hasta ahora tengo lo siguiente: Proyecto Android: Build.gradle: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.5.+' } } apply plugin: 'android' dependencies { […]

Intellij Idea log GradleConnectionException: No se pudo ejecutar la compilación usando la instalación de Gradle mientras se construye

Utilizo Intellij Idea 13.1.1 y obtengo GradleConnectionException mientras construyo: Error:org.gradle.tooling.GradleConnectionException: Could not execute build using Gradle installation 'C:\Users\<USER_NAME>\.gradle\wrapper\dists\gradle-1.10-all\6vpvhqu0efs1fqmqr2decq1v12\gradle-1.10'.: Could not execute build using Gradle installation 'C:\Users\<USER_NAME>\.gradle\wrapper\dists\gradle-1.10-all\6vpvhqu0efs1fqmqr2decq1v12\gradle-1.10'. He visto una pregunta similar aquí y la googleó. Pero no me ayudó. Al final encontré el registro buld de Idea y esta es la excepción con más detalles […]

¿Por qué no puedo importar el SDK de Facebook correctamente?

He añadido correctamente como una dependencia y poner el repositorio central maven como, no hay error en la importación ! Pero no puedo acceder a ningún método como el AppEventsLogger sólo dice para crear la clase y no importar. Estoy siguiendo los pasos de Facebook Quick Starts . Construir un gradiente apply plugin: 'com.android.application' android […]

Java.util.zip.ZipException: entrada duplicada con firebase

Estoy construyendo una aplicación con firebase pero obteniendo el error de clase Duplicate. He comprobado todas las dependencias, pero no soy capaz de averiguar dónde tengo dos versión de librerías firebase. Error: Error de ejecución para la tarea ': app: transformClassesWithJarMergingForDebug'. Com.android.build.api.transform.TransformException: java.util.zip.ZipException: entrada duplicada: com / google / firebase / iid / zzb $ […]

Cómo agregar .aar dependencia en el módulo de la biblioteca?

Tengo un archivo .aar de un módulo de biblioteca. Quiero usarlo como una biblioteca o dependencia en el módulo de biblioteca de mi otro proyecto. ¿Cómo lo hago? He probado las opciones disponibles en los enlaces siguientes: Http://kevinpelgrims.com/blog/2014/05/18/reference-a-local-aar-in-your-android-project/ Funciona solo si agrego .aar referencia .aar en el módulo de aplicación de mi proyecto. Pero no […]

Android: Cómo usar menor minSdkVersion que declarado en la biblioteca (uiautomator-v18)

He migrado una aplicación Android más antigua a Android-Studio / Gradle. La prueba necesita uiautomator-v18 que requiere minSdkVersion=18 . Sin embargo, me gustaría tener la minSdkVersion establecida en 15 o 16. Hay muchas preguntas sobre SO sobre la misma cosa, pero no soy capaz de resolver este problema. Exerpt AndroidManifest.xml: <manifest xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" package="com.example.searcher" android:versionCode="1" […]

Error: (19, 0) Gradle DSL método no encontrado: 'android ()'

Android Studio está dando este error al compilar el proyecto. He buscado y encontrado que esto puede suceder debido a androide Bloquear en la parte superior de la build.gradle.But en mi build.gradle puede no ser el problema. Aquí están mis archivos gradle. Construir un gradiente // Top-level build file where you can add configuration options […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.