Tag: build.gradle

ScriptC_ "nombre" no se genera después de crear un archivo .rs (en Android Studio con Gradle)

Acabo de comenzar renderscript en Android Studio. Cuando hago un archivo .rs, no se genera ni la clase ScriptC_DS ni un archivo .bc. He leído que se supone que se genera automáticamente una vez que se guarda el archivo .rs, así que no estoy seguro de lo que está mal. DS.rs #pragma version(1) #pragma rs […]

react-native run-android falló con error: Error de ejecución para la tarea ': app: dexDebug'

Estoy utilizando Windows 8.1. con react-native-cli: 1.0.0 y react-native: 0.31.0 Después de añadir react-native-maps al proyecto, corrí el comando react-native upgrade y dado Y a todas las preguntas. A continuación, vinculados deps con rnpm link , así como vienen los cambios a MainApplication.java archivo también. Estos son los cambios a MainApplication.java : // Other imports […]

ActionBarDrawerToggle Ningún constructor adecuado Drawable

Tengo un código simple para crear el cajón de navegación simple, pero cuando declaro el parámetro de ActionBarDrawerToggle es decir que el icono dibujable no se puede aplicar … Gradle Masajes Construir Error:(36, 26) error: no suitable constructor found for ActionBarDrawerToggle(MainActivity,DrawerLayout,int,int,int) constructor ActionBarDrawerToggle.ActionBarDrawerToggle(Activity,DrawerLayout,Toolbar,int,int) is not applicable (argument mismatch; int cannot be converted to Toolbar) constructor […]

android: app: transformClassesWithDexForDebug

Estoy cansado de resolver este error desde 2-3 horas. Por favor, ayúdame a salir de esto. Por lo tanto, tengo siguientes dependencias en mi archivo build.gradle (module: app): apply plugin: 'com.android.application' android { compileSdkVersion 23 buildToolsVersion "23.0.1" defaultConfig { applicationId "com.example.corpchat" minSdkVersion 14 targetSdkVersion 23 versionCode 1 versionName "1.0" multiDexEnabled true } buildTypes { release […]

No puede encontrar ProxyFrameworkImpl por nombre

Trabajo en Android Studio 1.3.1 con gradle 2.2.1. Mi aplicación se creó en eclipse y luego se trasladó a AS. Estoy haciendo pruebas usando Mockito, PowerMock y JUnit. Tengo problema con ProxyFrameworkImpl , estoy seguro de que mis frascos contienen esta clase – lo encontré en el explorador de proyectos en la sección Bibliotecas externas. […]

¿Cómo incluir applicationId en la línea de comandos desde la dependencia build.gradle?

Estoy tratando de seguir este Gist para desactivar las animaciones del sistema : task grantAnimationPermission(type: Exec, dependsOn: 'installDevDebug') { commandLine "adb shell pm grant $android.defaultConfig.applicationId android.permission.SET_ANIMATION_SCALE".split(' ') } tasks.whenTaskAdded { task -> if (task.name.startsWith('installDevDebugAndroidTest')) { task.dependsOn grantAnimationPermission } } Este código está intentando usar adb para conceder el permiso SET_ANIMATION_SCALE siempre que se ejecute una […]

Proyecto Android Wear con múltiples dimensiones de sabor

El problema Encontramos un problema con un proyecto que tiene múltiples (2) dimensiones de sabor de producto y un módulo de desgaste. En la construcción de un lanzamiento no recibimos errores de compilación y la aplicación de teléfono funciona, pero la aplicación de desgaste nunca se sincroniza para ver. Ejemplo de código El módulo de […]

cómo generar un informe de cobertura de código para androidTest utilizando Jacoco en el estudio android

Puedo generar el informe de la cobertura del código usando Jacoco para la carpeta de la prueba y también quiero generar el informe para el testcase del instrumento en la carpeta de androidTest. Por favor, comparta cualquier fragmento de código o enlace para referirse.

No se pueden cambiar los módulos buildVariant

Tengo un proyecto con una aplicación principal y 3 módulos. Dependen unos de otros como app (android application) | — module1 (android library) | — module2 (android library) | — module3 (android library) Estoy utilizando AS 3.0 con BuildTool 3.0.0-alpha5. He aplicado los cambios descritos en el doc: https://developer.android.com/studio/build/gradle-plugin-3-0-0-migration.html#variant_dependencies Aquí está mi build.gradle (app) apply […]

No se puede construir el proyecto Gradle con Android Studio

Estoy utilizando Android Studio 0.3.0 (configurado para utilizar gradle envoltorio para construir), Gradle 1.8. Cada vez que construyo (o reconstruyo) el proyecto con Android Studio, obtengo el error: Gradle: A problem occurred evaluating project ':MyProject'. > For input string: "" Al hacer clic en el error, aquí está el código de error en build.gradle: def […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.