Tag: android gradle

¿Es posible utilizar múltiples archivos de manifiesto para diferentes creaciones / sabores de gradle?

Digamos que tengo una aplicación de etiqueta blanca que estoy convirtiendo a ser construido en android studio de eclipse. Esta aplicación tiene alrededor de 10 iteraciones que todos utilizan principalmente la misma base de código con diferentes recursos que todos utilizan la misma convención de nombres cómo alguna vez algunas de las iteraciones tienen actividades […]

¿Cómo ignoro minSdkVersion de la biblioteca en Android Studio?

En mi proyecto minSdkVersion = 10, en la biblioteca es 11. Yo obtengo: BUILD_FAILED – Manifest merger failed : uses-sdk:minSdkVersion 10 cannot be smaller than version 11 declared in library. Cómo ignorar minSdkVersion de la biblioteca?

Android Studio 1.1 Gradle 2.2.1 Gradle versión 2.1 requiere la versión actual es 2.2.1

Estoy tratando de compilar la última versión de u2020-daggr2 en Android stu! [E Lo importé como un proyecto gradle. ¡Pero consigo el error que se queja sobre gradle! Edité el gradle-wrapper.properties. Reconstruir sin embargo no funcionó. Hice ver: Gradle 2.1 es necesario Migrar a Gradle envoltorio y el proyecto de sincronización que parece como el […]

Jenkins no puede resolver com.android.tools.build:gradle:3.0.0-alpha8

He actualizado a Android Studio versión 3.0 Canary 8 y seguido el auto-prompt en Android Studio para actualizar la versión androide gradle plugin a "3.0.0-alpha8". Mi compilación Jenkins ahora no logra resolver "com.android.tools.build:gradle:3.0.0-alpha8.". A continuación se muestran los registros de errores de compilación Could not resolve all files for configuration ':classpath'. Could not find com.android.tools.build:gradle:3.0.0-alpha8. […]

Tipo no admitido 'propiedad' en el archivo logback.xml

Quiero usar logback-android en el proyecto de Android. Esto es lo que he hecho He copiado los archivos jar en la carpeta libs Logback-android-1.1.1-2.jar Slf4j-api-1.7.6.jar Y tienen logback.xml en la carpeta de activos <configuration debug="true"> <property name="LOG_DIR" value="/mnt/sdcard/com.sf.quid/logs" /> <!– Create a logcat appender –> <appender name="LOG_CAT" class="ch.qos.logback.classic.android.LogcatAppender"> <encoder> <pattern>%msg</pattern> </encoder> </appender> <!– Rolling Appender […]

Android: La ejecución falló para la tarea ': app: packageDebug'. > Datos

Acabo de crear un proyecto de muestra y enfrentar este problema. ¿Puede alguien ayudar en esto para resolver esto? * What went wrong: Execution failed for task ':app:packageDebug'. > data * Try: Run with –info or –debug option to get more log output. * Exception is: org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':app:packageDebug'. at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:69) at […]

Dependencia apache cliente HTTP en android con API de Google

He estado usando las bibliotecas de servicios de Google Play sólo con el inicio de sesión de Google+ y funcionó bien, pero ahora quiero incluir la API de calendario en mi aplicación. Estoy siguiendo este tutorial El problema es que las dependencias con las nuevas instrucciones del tutorial provocan una advertencia en la generación de […]

Evitar la caché gradle para las versiones de instantánea

Estoy trabajando con versiones de SNAPSHOT de algunas bibliotecas en Android Studio. El problema es que Gradle parece utilizar una versión en caché de estas bibliotecas y no volver a cargar la nueva versión actualizada de la instantánea. Intenté usar algo como esto en mi script gradle, pero no funciona. dependencies { compile ('myGroupId:myArtifactId:XYZ-SNAPSHOT'){ changing=true […]

No hay versión en caché de gradle

Estoy recibiendo este error al sincronizar gradle. Soy bastante nuevo para Gradle por lo que no puede averiguar cuál es exactamente el problema? Error: No hay versión en caché de com.android.tools.build:gradle:0.10.1 disponible para el modo sin conexión. Cuando voy a Setting-> Gradle, tengo el modo offline activado y el uso de gradle wrapper por defecto.

Android studio Gradle :: dependencies {compilar 'com.android.support:appcompat-v7:18.0.0'} falla la compilación

Hace poco cambié a estudio de androide para el desarrollo. Había creado el proyecto con minsdk, targetsdk y compilar con sdk como Google Api Nivel 8. La compilación del proyecto falla debido al siguiente código en el archivo build.gradle. dependencies { compile 'com.android.support:appcompat-v7:18.0.0' } ¿Puede alguien decir por qué esto es hapenning? Mi build.gradle completo […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.