Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Tag: android gradle

Multidex Android, UnsatisfiedLinkError – no pudo encontrar el archivo .so

Estoy intentando agregar un poco de lib (.jar & .so) a mi proyecto multidex en android studio. Cuando añado solamente algunos tarros al proyecto todo trabaja muy bien. En caso de que añadir más y más jarras (otras libs) estoy recibiendo este error: java.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.test.digital.ocrtest-2/base.apk"],nativeLibraryDirectories=[/data/app/com.test.digital.ocrtest-2/lib/arm, /data/app/com.test.digital.ocrtest-2/base.apk!/lib/armeabi-v7a, /vendor/lib, /system/lib]]] couldn't find "libScanovatePassportAndIDLSDK_CPP.so" Cualquier idea […]

¿Cómo apuntamos androidTest a un Peer Eclipse-Style Project?

Estoy ayudando al Proyecto Guardian en NetCipher . Por motivos legados, quieren mantener su estructura de proyecto existente, basada en Eclipse. Sin embargo, en lugar de tener las pruebas en una tests/ subdirectorio de la biblioteca, fueron con un modelo de proyecto de iguales. Así, fuera de la raíz de repo, libnetcipher/ es la biblioteca […]

Vinculación de datos – safeUnbox warning

Después de actualizar AS gradle versión a 2.3.0, enlace de datos encuentro una advertencia: Advertencia: selectMap [index] es un campo en caja, pero necesita ser desactivado para ejecutar selectMap [index]? @android: color / blanco: @android: color / transparente. Esto puede causar NPE, de modo que la vinculación de datos lo desacoplará con seguridad. Puede cambiar […]

Cómo copiar activos de depuración para pruebas de unidad

Tengo un proyecto del gradle de la biblioteca del androide. Y necesito copiar algunos archivos a la carpeta de activos para pruebas de unidad robolectric. Para hacerlo he definido una tarea de copia: task copyDebugAssets(type: Copy) { from "${projectDir}/somewhere" into "${buildDir}/intermediates/bundles/debug/assets" } Pero no puedo agregar esta tarea como una tarea de dependencia para processDebugResources […]

Cómo editar el código de una biblioteca importada con Gradle en Android Studio?

Estoy enfrentando un pequeño problema con una de mis bibliotecas en Android Studio. Este se importa con un archivo Gradle, como este: dependencies { compile 'com.github.navasmdc:MaterialDesign:1.5@aar' } Tiene un problema conocido de su repositorio GitHub pero solo puedo corregirlo editando una línea de código en un archivo de esta biblioteca … El problema es que […]

Problema de migración de desarrollo nativo de Android Studio 2.2

Antes de hacer el cambio a AS 2.2, tengo la siguiente estructura para implementar mi C app/src/main/jni/Android.mk app/src/main/jni/Application.mk app/src/main/jni/headers/* app/src/main/jni/cfiles*.cc En cuyo caso todo bien. Sin embargo, después de actualizar a AS 2.2, no puedo construir ningún apk y siempre recibo el siguiente error: Execution failed for task':app:transformNative_libsWithStripDebugSymbolForDebug java.lang.NullPointerException (no error message) ¿Alguien sabe a […]

¿Es obligatorio usar Gradle con Android Studio?

Estoy usando android studio desde su lanzamiento oficial. Hasta ahora, que uso Android Studio versión 2.1.2, tengo que esperar horas para importar un proyecto por primera vez y dejar gradle sincronizar. Algunas personas recomiendan para ejecutar androide estudio en modo offline, pero cuando quiero utilizar las bibliotecas externas tengo que hacer mi proyecto sincronizado y […]

Cómo bajar la versión proguard en androide gradle estudio?

Estoy intentando construir una aplicación para Android usando scala y android studio. La compilación falla en proguard con una excepción: Error:java.lang.ArrayIndexOutOfBoundsException: 4 at proguard.classfile.editor.InterfaceDeleter.visitSignatureAttribute(InterfaceDeleter.java:162) at proguard.classfile.attribute.SignatureAttribute.accept(SignatureAttribute.java:97) Encontré en otro lugar ( http://sourceforge.net/p/proguard/bugs/549/ ) que este problema es causado por un error en scala, pero que sólo ocurre en proguard 5.1 y no en proguard 5.0. […]

AS obligar a utilizar android SDK Build Tools 25.0.0 SDK herramientas de compilación revisión (23.0.3) es demasiado bajo para el proyecto

Hola estoy frente a la versión de la versión de construcción. Cuando ejecuto la aplicación, arroja un error que, Error: La revisión Herramientas de generación de SDK (23.0.3) es demasiado baja para proyecto ': Yampp'. El mínimo requerido es 25.0.0 Necesito usar 23.0.3, pero es forzar a usar 25.0.0. ¿Cómo resolver el extraño problema? Aquí […]

Error en la sincronización de Android Studio 3.0 Gradle: java.lang.AssertionError (en UnresolvedDependenciesReporter)

Al migrar a Android Studio 3.0-beta1, estoy corriendo en un fallo de sincronización de gradle error que no proporciona mucha información. No hay ningún mensaje de error en la consola gradle. Tuve que ir al archivo idea.log para obtener la siguiente traza de pila: java.lang.RuntimeException: java.lang.AssertionError at com.intellij.openapi.application.TransactionGuardImpl.submitTransactionAndWait(TransactionGuardImpl.java:174) at com.intellij.openapi.command.WriteCommandAction.execute(WriteCommandAction.java:155) at com.android.tools.idea.gradle.project.sync.idea.data.service.ModuleModelDataService.importData(ModuleModelDataService.java:80) at com.android.tools.idea.gradle.project.sync.idea.data.service.ModuleModelDataService.importData(ModuleModelDataService.java:50) at […]

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.