Tag: Android estudio

Gradle muestra un error en la biblioteca de soporte: "La versión del módulo com.android.support:support-v13:19.0.1 depende de las bibliotecas pero no es una biblioteca en sí"

Esto es lo que mi build.gradle dice: apply plugin: 'android' apply plugin: 'crashlytics' apply from : '../gradle/checkstyle.gradle' apply from : '../gradle/pmd.gradle' compileSdkVersion 19 buildToolsVersion "19.0.3" defaultConfig { minSdkVersion 17 targetSdkVersion 19 } Pero veo este error de compilación: Gradle 'mobi-client-connect-android-mobile' project refresh failed: Module version com.android.support:support-v13:19.0.1 depends on libraries but is not a library itself

Cómo eliminar las ventanas de herramientas innecesarias en Android Studio?

Estoy hablando de esto: (Para aquellos que se preguntan: Es la "Captura" y "Proyecto Maven" ventana de la herramienta.) He intentado ver View -> Tool Windows , pero parece que sólo puedo añadir una nueva ventana, no quitar una. Alguien sabe cómo hacer esto? No es una gran cosa de un acuerdo que sé, pero […]

No se puede salir de svn

Cuando intento salir de svn , está mostrando esta alert . Ya estoy usando este enlace svn y trabajando en esto durante los últimos dos meses. Necesitaba la misma copia del proyecto de svn en una nueva ventana para algún otro trabajo. Pero, cuando trato de pagar, muestra esta alerta. ¿Podría alguien ayudar?

¿Qué tarea de gradle extrae dependencias de repositorios remotos?

Estoy haciendo el cambio a Gradle para mi proyecto de Android. He importado el proyecto en Android Studio de Eclipse y lo he envuelto con Gradle 1.8. Mi supuesto fue Gradle manejado dependencias de la manera como Maven, es decir, si se especifica una dependencia que no existe en su repositorio local se tirará de […]

Cómo importar la biblioteca y los módulos a android studio correctamente

Quiero usar esta biblioteca ( https://github.com/ikimuhendis/LDrawer ) en mi proyecto. Pero cuando lo importo como nuevos módulos no puedo ver dónde está? Y entonces se produce un error gradle como este: No puedo encontrar runProguard Y luego lo reemplazé con minifyEnabled, entonces este error ocurre "cambiar gradle version Error: Los proyectos de biblioteca no pueden […]

Android Studio 0.5.9 código de error 42

Cada vez que intento importar un proyecto desde eclipse recibo un error como ese Error:Execution failed for task ':app:mergeDebugResources'. Error: Error al ejecutar el comando: D: \ Android \ sdk \ build-tools \ 19.1.0 \ aapt.exe s -i C: \ projects \ ZwallU \ app \ src \ main \ res \ drawable-hdpi \ filgoal.png […]

Error: Error de ejecución para la tarea ': app: processDebugGoogleServices

Tengo un error en Android Studio. Nueva aplicación de actividad en blanco, agrego "build.gradle (project)" dependencies { classpath 'com.android.tools.build:gradle:2.0.0-alpha9' classpath 'com.google.gms: google-services: 2.0.0-alpha9' } Y en "build.gradle (app)" dependencies { compile FileTree (dir: 'libs', include: ['* .jar']) compile 'com.android.support:appcompat-v7:23.0.1' compile 'com.android.support:design:23.0.1' // Dependency for Google Sign-In compile 'com.google.android.gms: play-auth-services: 8.4.0' } apply plugin: 'com.google.gms.google-services' Compilar, […]

Nuevo archivo de diseño content_xxxxx.xml en Android Studio 1.4

Acabo de actualizar Android Studio de 1,3 a 1,4 y hay algunas nuevas características que no me dan. Al crear una nueva Blank Activity , se agregan dos archivos de diseño .xml. El nombre de mi actividad es PaymentActivity , así que obtendré content_payment.xml y activity_payment.xml . Este archivo content_payment.xml no contiene nada que no […]

¿Cómo ejecutar un proyecto de Android Studio directamente desde el Finder?

¿Cómo abrir un proyecto de Android Studio desde el Finder? Veo la siguiente lista de archivos. ¿Es posible hacer doble clic en uno de ellos para que sea abierto por Android Studio?

Android – capaz de utilizar AppCompatActivity sin la biblioteca de soporte

En build.gradle mi aplicación, las dependencias son: compile 'com.android.support:support-v4:22.0.0' compile 'com.android.support:recyclerview-v7:22.0.0' compile 'com.android.support:cardview-v7:22.0.0' compile 'com.android.support:support-v13:22.0.0' compile 'com.android.support:palette-v7:22.0.0' compile 'com.android.support:design:22.2.1' compile 'com.android.support:percent:22.2.0' compile 'com.google.android.gms:play-services:7.0.0' Sin compile 'com.android.support:appcompat-v7:22.0.0' , todavía puedo usar AppCompatActivity y ActionBar que son de soporte de la biblioteca v7. Cualquier respuesta explicando las razones detrás será apreciada 🙂

FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.