Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Android Studio Versión no compatible del complemento Gradle

Similar a la pregunta hecha aquí: Android Studio no compatible versión de gradle pero estoy usando una versión compatible , pero la respuesta allí no soluciona el problema para mí.

Estoy usando Android Studio Beta 0.8.1 ejecutándose bajo Ubuntu 14.04 LTS. Estoy intentando importar un proyecto que se comparte con mi equipo, pero cuando clupo el proyecto e intento construirlo, consigo este error:

Error:The project is using an unsupported version of the Android Gradle plug-in (0.11.2) <a href="fixGradleElements">Fix plug-in version and re-import project</a> 

Cuando hago clic en el enlace, obtengo este error:

 12:21:30 PM Quick Fix Failed Unable to find any references to the Android Gradle plug-in in build.gradle files. Please click the link to perform a textual search and then update the build files manually. 

Aquí está la sección relevante de mi archivo build.gradle:

 buildscript { ... dependencies { classpath 'com.android.tools.build:gradle:0.11.+' } } 

He instalado manualmente una versión reciente de Gradle en un intento de rectificar este problema (Ubuntu realmente sólo quiere dejarme tener la versión 1.4, pero nuestro proyecto está configurado para Gradle 1.11 + Aquí está la salida de "gradle -v":

 ------------------------------------------------------------ Gradle 1.11 ------------------------------------------------------------ Build time: 2014-02-11 11:34:39 UTC Build number: none Revision: a831fa866d46cbee94e61a09af15f9dd95987421 Groovy: 1.8.6 Ant: Apache Ant(TM) version 1.9.2 compiled on July 8 2013 Ivy: 2.2.0 JVM: 1.8.0_05 (Oracle Corporation 25.5-b02) OS: Linux 3.13.0-30-generic amd64 

He intentado configurar Android Studio para que utilice la instalación local de Gradle (File> Settings> Gradle> Use local gradle distribution), pero esto sólo produce un error que una tarea dada no se puede encontrar en el proyecto raíz. (?)

Cuando construyo el proyecto desde la línea de comandos con el comando "./gradlew clean assembleDebug", se construye perfectamente y puedo instalar y ejecutar el APK.

No entiendo lo que estoy haciendo mal, o cómo solucionarlo. ¡Cualquier pista sería apreciada profundamente!

  • El complemento de Android Studio es demasiado antiguo
  • No se puede encontrar el botón "Sincronizar proyecto con archivos Gradle" en IntelliJ IDEA
  • Android Studio: Importación de proyecto al proyecto existente
  • ¿Puedo establecer un indicador BuildConfig que devuelve si un apk se ha construido o no con la tarea gradled `connectedAndroidTest`?
  • Error en la ejecución de la tarea: app: compileDebugJavaWithJavac
  • Cambiar el nombre de apk con Gradle
  • Los informes de pelusa de Android Studio "no pueden deducir tipos de argumentos".
  • ¿Cómo reemplazar una cadena por un buildvariant con gradle en android studio?
  • 3 Solutions collect form web for “Android Studio Versión no compatible del complemento Gradle”

    Android Studio 0.8.1 requiere el gradle-plugin 0.12.

     buildscript { ... dependencies { classpath 'com.android.tools.build:gradle:0.12.+' } } 

    Compruebe la compatibilidad de esta respuesta:

    Android Studio Gradle problema de actualización a la versión 0.5.0 – Gradle de la migración de 0,8 a 0,9 – También Android Studio actualización a 0,8.1

    Ahora entiendo lo que estaba haciendo mal. La versión más reciente de Andoid Studio que he instalado no admite el complemento gradle 0.11. *. La solución es actualizar todos mis archivos build.gradle así:

     buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.12.+' } } 

    Así que he cambiado el gradle: 0.11. + 'A' gradle: 0.12. + '.

    Al abrir el archivo build.gradle (s) y mirando los mensajes de error que se mostraron en las líneas pertinentes, pude ver que eran mucho más útiles que los mensajes de error que originalmente se enfrentó. Estaba buscando alguna forma de actualizar mi instalación de gradle, o mi plugin gradle en Android Studio. Lo que Android Studio quería era que actualizara el archivo de compilación para especificar una versión diferente de plugin de gradle. No entiendo por qué eso era realmente necesario – ¡No he cambiado nada en el código fuente! – pero Android Studio ahora felizmente construir y ejecutar mi proyecto.

    Gracias a Gabriele Mariotti por aclaración.

    También tengo este error en Linux Mint 17.

    Había instalado gradle desde los repositorios de Ubuntu pero era la versión 1.4. Así que descargé 1.10 usando el ppa:

     sudo add-apt-repository ppa:cwchien/gradle sudo apt-get update sudo apt-get install gradle-1.10 

    Nota No haga sudo apt-get install gradle , ya que la versión más reciente (2.x en este momento) también es rechazada por Android Studio

    FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.