Android studio: La actualización del proyecto falló .. error al abrir el archivo zip

He instalado Android Studio en mi computadora portátil y también ejecuto las actualizaciones de 0.52 a 0.61

Después de crear un nuevo proyecto o abrir un proyecto de ejemplo que he descargado, muestra este error:

Gradle '{ProjectName}' project refresh failed Error:Cause: error in opening zip file 

No pude encontrar nada relacionado con este error específico en Google o en ningún otro sitio de Stackoverflow.

¿Por favor ayuda?

descargar manualmente

http://downloads.gradle.org/distributions/gradle-1.12-all.zip

y pegar: (sin descomprimir)

C: \ Users \ (NOMBRE DEL USUARIO) \ .gradle \ wrapper \ dists \ gradle-1.12-all [código hash] /

C: \ Users \ (NOMBRE DEL USUARIO) \ .gradle \ wrapper \ dists \ gradle-1.12-all [código hash] /gradle-1.12-all.zip

actualizar

Para Mac OS X y otro sistema operativo basado en Unix, la ruta es

~ / .gradle / wrapper / dists / gradle-1.x / [código hash] /

Tuve el mismo problema después de actualizar Android Studio de 2.2.3 a 2.3; Aquí está la solución que funcionó para mí:

1) En su proyecto abra 'gradle-wrapper.properties', cambie el valor 'distributionUrl'

 distributionUrl=https\://services.gradle.org/distributions/gradle-3.3-all.zip 

2) En su proyecto abra el archivo 'build.gradle' del proyecto y cambie el classpath

  classpath 'com.android.tools.build:gradle:2.3.0' 

Este es el último ajuste de gradle.

Espero que este trabajo.

NOTA : La versión del gradle depende de su versión de estudio de Android. Así que cambia la versión (como en el código) de acuerdo con eso.

He arreglado este problema por …

  • Ir a Configuración …> Gradle
  • Seleccionando "Utilizar distribución local Gradle".
  • Lo señalé a mi archivo zip de Gradle: home / kersting / .gradle / wrapper / dists / gradle-1.12-all / 6vpvhqu0efs1fqmqr2decq1v12 / gradle-1.12

Debe ser algo similar para usted si ha descargado Gradle que debería tener cuando descargó Android Studio. Tenga cuidado, el archivo .gradle puede estar oculto. Lo encontré a través de la terminal, pero "ls" no lo reveló.

  • Excluyendo ciertos módulos de proguard Android Gradle Buildscript
  • Archivo bajo / res / raw no accesible en Debug buildvariant
  • No se pudo encontrar com.google.android.gms: play-services: 7.0.0
  • Error "Se requiere la versión 1.10 de Gradle. La versión actual es 1.12. "Al ejecutar" gradle wrapper "?
  • La generación de grados falla para la excepción de host desconocido
  • Biblioteca de Soporte de Diseño v22.2 "EXCEPCION DE NIVEL INESPERADO"
  • Eliminación del elemento AndroidManifest con los sabores de producto gradle
  • AndroidManifest.xml para Gradle instrumentTest
  • ¿Cómo dividir la lógica build.gradle en archivos más .gradle?
  • Publicar archivo .aar con javadocs adjunto en repo artifactory
  • DEX falla al analizar un frasco incluyendo BuildConfig y R usando Gradle, pero trabajó con Ant
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.