Android Studio gradle construir con éxito a pesar del error de nivel de api

Estoy trabajando en un proyecto de Android que Api nivel es de 10, es declarado en build.gradle y AndroidManifest.xml archivos

defaultConfig { minSdkVersion 10 targetSdkVersion 15 } <uses-sdk android:minSdkVersion="10" android:targetSdkVersion="15" /> 

Cuando utilizo la clase ActionBar Android Studio Editor subrayó esta línea y dio aviso como esperaba "Llamada requiere API nivel 11 (min actual es 10): android.app.ActionBar …"

Pero cuando compile el proyecto, se compila con éxito. Puede ser causa de errores, ¿cómo se puede trabajar en los dispositivos API lvl 10. Quiero un error sobre esto, pero compilado.Cómo puedo obtener un error de compilación acerca de esto. Ty

2 Solutions collect form web for “Android Studio gradle construir con éxito a pesar del error de nivel de api”

Lo que está viendo es la herramienta de pelusa de Android que muestra errores, pero Android Studio todavía permite la compilación.

Esto se debe a que los errores de pelusa que ve no impiden la compilación. Parece que Android Studio (al menos en v1.3.2) el proceso de construcción ignora errores de pelusa durante la compilación de forma predeterminada, mientras que en Eclipse w / ADT plugin no sería capaz de compilar.

Buscando Mejorar con Lint , puede modificar su archivo build.gradle con opciones de pelusa para que la compilación no funcione:

 android { lintOptions { // if true, stop the gradle build if errors are found abortOnError false } } 

Cambiar a continuación …

 defaultConfig { minSdkVersion 11 targetSdkVersion 15 } <uses-sdk android:minSdkVersion="11" android:targetSdkVersion="15" /> 

Después de ajustar gradle o menifest. Limpiar y reconstruir su proyecto. Espero que funcione …. si todavía no está trabajando la herramienta del recomenzar e intenta compilar el proyecto otra vez ….

  • No se pudo notificar al oyente de evaluación del proyecto en Android gradle
  • Gradle: ¿Cómo personalizar los permisos de Manifiesto de Android?
  • No puede instalar el repositorio y el proyecto de sincronización - no puede utilizar las bibliotecas de soporte 25.2.0
  • ¿Cómo reemplazar una cadena por un buildvariant con gradle en android studio?
  • Cómo incluir el archivo versionado * .so en apk usando Gradle?
  • No se puede ejecutar gradle
  • Compile 'com.android.support:multidex:1.0.1' sucedió mal: todas las bibliotecas de soporte técnico de android deben usar la misma versión
  • Agrega android-support-v13.jar en Android Studio
  • Android Studio publica una biblioteca local
  • Uso de intelliJ con gradle OFFLINE para el desarrollo de android
  • Android Studio: migrar complejo build.xml a build.gradle
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.