Join FlipAndroid.COM Telegram Group: https://t.me/joinchat/F_aqThGkhwcLzmI49vKAiw


Android studio – Error de secuencia de comandos de compilación, no compatible con el método Gradle DSL encontrado: 'android ()'!

Estoy recibiendo el siguiente error en Android Studio 0.4.2 cuando estoy tratando de sincronizar el proyecto con gradle.

Gradle 'GooglePlayServicesTest' project refresh failed: Build script error, unsupported Gradle DSL method found: 'android()'! 

Mis proyectos gradle archivo es el siguiente: –

 buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.7.+' } } allprojects { repositories { mavenCentral() } } android{ compileSdkVersion 19 buildToolsVersion "19.0.1" defaultConfig { minSdkVersion 10 targetSdkVersion 19 versionCode 1 versionName "1.0" } sourceSets{ main{ manifest.srcFile 'GooglePlayServicesTest/src/main/AndroidManifest.xml' } } } 

Gradle archivo del módulo : –

 apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion "19.0.1" defaultConfig { minSdkVersion 10 targetSdkVersion 19 versionCode 1 versionName "1.0" } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile 'com.android.support:appcompat-v7:+' } 

También he quitado la miniSDKVersion y targetSDKVersion de AndroidManifest.xml

Puede alguien ayudarme a solucionar este error.

2 Solutions collect form web for “Android studio – Error de secuencia de comandos de compilación, no compatible con el método Gradle DSL encontrado: 'android ()'!”

android método en el archivo de gradle proyecto no es needed.Try para eliminarlo.

Agregue la parte superior de su archivo build.gradle proyecto:

 apply plugin: 'com.android.application' 
FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.