Android Studio dice usar Gradle 1.10 – pero la nueva versión es 1.12?

El error:

The project is using an unsupported version of Gradle. Please use version 1.10. My `gradle.build` file says this: dependencies { classpath 'com.android.tools.build:gradle:0.12.+' } 

Por lo que sé, la línea anterior es correcta. Mi archivo gradle-wrapper dice:

 distributionUrl=http\://services.gradle.org/distributions/gradle-1.12-all.zip 

Esto sucedió cuando descargué la versión beta más reciente de Android Studio (v.8) y traté de importar una aplicación que tenía, lo que supongo que es una versión antigua de Gradle.

Además, cuando golpeo " Fix Gradle Wrapper and re-import project ", no pasa nada.

3 Solutions collect form web for “Android Studio dice usar Gradle 1.10 – pero la nueva versión es 1.12?”

Si desea cambiar el gradle-wrapper a una versión inferior, tiene que cambiar distributionUrl a

 distributionUrl=http\://services.gradle.org/distributions/gradle-1.10-all.zip 

Y vuelva a ejecutar la tarea de contenedor. Si esto no es suficiente, simplemente elimine las carpetas .gradle y gradle y los archivos gradlew y gradlew.bat . El envoltorio de rerun y descarga descargas gralde 1.10

Dado que gradle tuvo algunos cambios importantes de api desde la versión 1.10 y 1.12 no se puede construir ningún proyecto con una versión superior, entonces los plugins son construir con. Así que si el plugin de Android es construir con gradle 1.10 tienes que usar la misma versión

Error: "Gradle versión 1.10 es necesaria La versión actual es 2.0"

Por qué se muestra: Intentando crear un proyecto de Android que requiera la versión 1.10 de Gradle mientras usa la versión 2.0 de él como nativo.

Qué debe hacerse para resolver este problema: Actualización de la versión gradle dentro del archivo build.gradle

 dependencies { classpath 'com.android.tools.build:gradle:0.12.2+' } 

Sustituyéndolo por

 dependencies { classpath 'com.android.tools.build:gradle:1.0.+' } 

Hay una diferencia entre la versión de Gradle y la versión de Gradle Android Plugin (0.12. +).
Parece que necesitas Gradle versión 1.10, no creo que las versiones posteriores son supuestas por el Gradle Android plugin todavía. De todos modos, creo que asegurarse de que utiliza Gradle 1.10 versión resolverá este problema.

  • ¿Cómo evitar la copia de seguridad automática de una aplicación de Android?
  • Operador ternario devuelve valor - Java / Android
  • Emulación de etiquetas RFID en el emulador de Android
  • Módulo dependiendo de otro módulo en Dagger
  • Volley: MultipartRequest.getBody: Escritura de IOException a ByteArrayOutputStream
  • ¿Es una mala idea usar printStackTrace () en Android Exceptions?
  • Alcance de System.setProperty
  • Android RelativeLayout cambia de color onClick
  • Cambiar la vista establecida drawables para el pulgar y la pista de tamaño específico
  • Notificación Push de Android C2DM
  • Lollipop AppBarLayout / Barra de herramientas que falta la animación de overscroll
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.