Android Studio 1.1 Gradle 2.2.1 Gradle versión 2.1 requiere la versión actual es 2.2.1

Estoy tratando de compilar la última versión de u2020-daggr2 en Android stu! [E Lo importé como un proyecto gradle. ¡Pero consigo el error que se queja sobre gradle! Edité el gradle-wrapper.properties. Reconstruir sin embargo no funcionó. Hice ver: Gradle 2.1 es necesario Migrar a Gradle envoltorio y el proyecto de sincronización que parece como el mismo problema, pero en Studio no encontré:

Ajustes -> Gradle y haga clic en Use gradle wrapper por defecto (recomendado).

No encontré dónde hacer esto en Studio. En primer lugar no hay menú que sólo dice Configuración. Hay: Archivo-> Otros ajustes-> Configuración predeterminada. Pero nada más que gradle vm parámetros, etc Nada sobre el uso de gradle envoltorio por defecto. Introduzca aquí la descripción de la imagen ¿Necesito tener una copia local de gradle 2.1 para que esto funcione? Introduzca aquí la descripción de la imagen ! [Escriba aquí la descripción de la imagen] [4] Introduzca aquí la descripción de la imagen

Gradle wrapper.properties se edita como tal: distributionUrl = https: //services.gradle.org/distributions/gradle-2.1-all.zip

Error: (20) Se ha producido un error al evaluar el proyecto raíz 'u2020-dagger2'.

Error al aplicar el complemento [id 'com.android.application'] Gradle versión 2.1 es necesario. La versión actual es 2.2.1. Si utiliza el gradlewrapper, intente editar la distributionUrl en / Users / Mac1 / Downloads / u2020-dagger2 /gradle/wrapper/gradle-wrapper.properties para gradle-2.1-all.zip

2 Solutions collect form web for “Android Studio 1.1 Gradle 2.2.1 Gradle versión 2.1 requiere la versión actual es 2.2.1”

Tienes que usar este gradle-plugin en tu build.gradle

 classpath 'com.android.tools.build:gradle:1.1.0' 

Android Studio 1.1.0 requiere:

  • Gradle 2.2.1 (puede establecer este valor en gradle-wrapper.properties )

  • Gradle plugin 1.0.0 / 1.1.0 (puede establecer este valor en su build.gradle )

Haga clic en su archivo build.gradle en el explorador de proyectos y realice cambios como

 dependencies { classpath 'com.android.tools.build:gradle:1.1.2 } 

¡Reconstruya su proyecto! Espero que esto ayude.

  • 'No se puede resolver el símbolo' y 'No se encontró ningún recurso que coincida con el nombre dado' - no un duplicado
  • A condición de que la dependencia de grado sea AAR no JAR
  • Gradle y dependencias no transitivas anidadas
  • Android, Gradle. Cómo construir aplicaciones y ejecutar pruebas desde la aplicación de prueba
  • Problemas con la adición de dependencias de telas a un proyecto construido cordova
  • Uso de $ {applicationId} en el manifiesto de la biblioteca
  • El demonio de compilación de Gradle desapareció inesperadamente (puede haber sido destruido o puede haberse estrellado) mientras construía un proyecto de Android en Jenkins
  • INSTALL_FAILED_DEXOPT Error en Android 5.0 en modo de liberación
  • Gradle de Android, libs nativas para diferentes arquitecturas
  • app: transformClassesWithJarMergingForDebug '. TransformException: java.util.zip.ZipException: entrada duplicada mientras se ejecuta gradlew assembleDebug
  • Firma de android apk con gradle-experimental: 0.2.0
  • FlipAndroid es un fan de Google para Android, Todo sobre Android Phones, Android Wear, Android Dev y Aplicaciones para Android Aplicaciones.